Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49504 - [virtualbox] Random crashes since linux 4.6 landed in testing.

Attached to Project: Community Packages
Opened by Frederic Bezies (fredbezies) - Sunday, 29 May 2016, 13:43 GMT
Last edited by Sébastien Luttringer (seblu) - Sunday, 12 June 2016, 16:45 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I don't know if it is the right category, sorry if not.

I noticed random crashes in VirtualBox since linux 4.6 landed on testing. It happens with any linux distributions I wanted to run in Virtualbox.

Kinda randomly, but only in big upgrades or install process, VirtualBox crashes. I opened a thread on virtualbox forum, without a lot of luck.

https://forums.virtualbox.org/viewtopic.php?f=7&t=77849

So I open a bug here :)

Additional info:
VirtualBox 5.0.20-1
virtualbox-host-modules-arch 5.0.20-4
Linux 4.6-1

Steps to reproduce: Archlinux with testing and VirtualBox. Try to install Archlinux. Random crashes. Happens when I want to install LibreOffice for example.
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Sunday, 12 June 2016, 16:45 GMT
Reason for closing:  Upstream
Comment by Frederic Bezies (fredbezies) - Sunday, 29 May 2016, 13:44 GMT
A log when a VBox machine crashed on start.

Hope it helps...
   VBox.log (177.8 KiB)
Comment by Frederic Bezies (fredbezies) - Monday, 30 May 2016, 17:39 GMT
Looks like a ticket is opened on VirtualBox bug tracker : https://www.virtualbox.org/ticket/15439

Related to CONFIG_X86_INTEL_MEMORY_PROTECTION_KEYS option ?

I can find it on kernel configs attached in VirtualBox ticket. Just an educated guess, of course :)
Comment by Frederic Bezies (fredbezies) - Thursday, 02 June 2016, 12:54 GMT
Linux kernel 4.6.1-1 doesn't change anything. Got another crash while "testing" VirtualBox with archboot ISO. Crash happened when installer wants to copy file from cdrom image to virtual disk. Attaching crash log.
   VBox.log (303.5 KiB)
Comment by Ralf Mardorf (Ralf) - Thursday, 09 June 2016, 09:09 GMT
Hi,

after upgrading from 4.5.4-1-ARCH (x86_64) to 4.6.1-2-ARCH (x86_64) virtualbox 5.0.20-1 crashes.

Just in case I removed and rebuild the modules [1] and run Virtualbox again, but it still stops working with a "Guru Meditation" [2].

After downgrading linux-headers and linux to 4.5.4-1-ARCH virtualbox 5.0.20-1 runs without issues.

Regards,
Ralf

[1]
[root@archlinux rocketmouse]# dkms remove vboxhost/5.0.20_OSE -k $(uname -r)

-------- Uninstall Beginning --------
Module: vboxhost
Version: 5.0.20_OSE
Kernel: 4.6.1-2-ARCH (x86_64)
-------------------------------------
[snip]
DKMS: uninstall completed.
[root@archlinux rocketmouse]# dkms install vboxhost/5.0.20_OSE -k $(uname -r)
[snip]
DKMS: install completed.

[2]
[rocketmouse@archlinux ~]$ grep VMSetError /home/rocketmouse/VirtualBox\ VMs/winos7/Logs/VBox.log
00:02:36.145916 VMSetError: /build/virtualbox/src/VirtualBox-5.0.20/src/VBox/VMM/VMMR3/MM.cpp(685) int MMR3AdjustFixedReservation(PVM, int32_t, const char*); rc=VERR_VMM_SET_JMP_ABORTED_RESUME
00:02:36.145948 VMSetError: Failed to reserve physical memory (0x1406 -> 0x1402; VMMDev Heap)
00:02:36.146418 VMSetError: /build/virtualbox/src/VirtualBox-5.0.20/src/VBox/VMM/VMMR3/MM.cpp(685) int MMR3AdjustFixedReservation(PVM, int32_t, const char*); rc=VERR_VMM_SET_JMP_ABORTED_RESUME
00:02:36.146430 VMSetError: Failed to reserve physical memory (0x1406 -> 0x1006; VMMDev)
00:02:36.148280 VMSetError: /build/virtualbox/src/VirtualBox-5.0.20/src/VBox/VMM/VMMR3/MM.cpp(685) int MMR3AdjustFixedReservation(PVM, int32_t, const char*); rc=VERR_VMM_SET_JMP_ABORTED_RESUME
00:02:36.148305 VMSetError: Failed to reserve physical memory (0x1406 -> 0x406; VRam)
00:02:36.150068 VMSetError: /build/virtualbox/src/VirtualBox-5.0.20/src/VBox/VMM/VMMR3/MM.cpp(685) int MMR3AdjustFixedReservation(PVM, int32_t, const char*); rc=VERR_VMM_SET_JMP_ABORTED_RESUME
00:02:36.150092 VMSetError: Failed to reserve physical memory (0x1406 -> 0x1405; Hyper-V hypercall page)
00:02:36.150136 VMSetError: /build/virtualbox/src/VirtualBox-5.0.20/src/VBox/VMM/VMMR3/MM.cpp(685) int MMR3AdjustFixedReservation(PVM, int32_t, const char*); rc=VERR_VMM_SET_JMP_ABORTED_RESUME
00:02:36.150144 VMSetError: Failed to reserve physical memory (0x1406 -> 0x1405; Hyper-V TSC page)
Comment by Frederic Bezies (fredbezies) - Thursday, 09 June 2016, 09:19 GMT
Always the same file and the same line : src/VBox/VMM/VMMR3/MM.cpp(685)

See bug report on VirtualBox bug tracker : https://www.virtualbox.org/ticket/15439
Comment by Samantha McVey (samcv) - Thursday, 09 June 2016, 09:29 GMT
I very much think this is a problem with VirtualBox and not Arch, and I would ask you to try the 4.7RC2 kernel... but I tried that with virtualbox-host-dkms and the modules don't even compile with DKMS (this is with AUR package linux-mainline and associated headers)! I would continue to pursue this with the VirtualBox bug bug tracker linked to in the comments. I see fredbezies is already posting there.
Comment by Frederic Bezies (fredbezies) - Sunday, 12 June 2016, 16:26 GMT
Looks like this bug won't be fixed until VirtualBox 5.1 is released. See this bug update -> https://www.virtualbox.org/ticket/15439#comment:18
Comment by Sébastien Luttringer (seblu) - Sunday, 12 June 2016, 16:45 GMT
For the record, my VMs (Windows, Arch) are working correctly with 4.6.0-seblu and this vbox release.

Loading...