Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49483 - [lvm2] lvm2-activation-generator wrongly syncs on ipc

Attached to Project: Arch Linux
Opened by Jonathan Roemer (pid1) - Friday, 27 May 2016, 12:10 GMT
Last edited by Christian Hesse (eworm) - Monday, 30 May 2016, 20:11 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Thomas Bächler (brain0)
Christian Hesse (eworm)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

Enabling services pauses, and then returns the following:

"Failed to execute operation: Connection timed out"

Disabling services pauses, and then returns the following:

"Failed to reload daemon: Connection timed out"

Steps to reproduce:

Upgrade to lvm2 2.02.153-1 or 2.02.154-1. Occurs under both systemd 229 and 230.

run "sudo systemctl enable <foo>" on any service.

Workaround:

Dropping sudo from the command allows systemd to operate as expected.

Upstream bug report:

https://github.com/systemd/systemd/issues/3353
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 30 May 2016, 20:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  lvm2 2.02.154-3 in [testing]
Comment by teraflops (teraflops) - Friday, 27 May 2016, 23:44 GMT
the workaround does not work. I get the issue as root in tty or as user without sudo letting PolicyKit1 handle the authentication. I even have the issue using GDM or just startx. I checked downgrading polkit/dbus/systemd, no luck.
Comment by Jonathan Roemer (pid1) - Saturday, 28 May 2016, 04:44 GMT
This can be reassigned, as it is a lvm2-activation-generator issue. See https://github.com/systemd/systemd/issues/3353#issuecomment-222283205
Comment by Christian Hesse (eworm) - Monday, 30 May 2016, 09:07 GMT
Just pushed lvm2 2.02.154-2 to [testing]. Anybody wants to give it a try?
Comment by Tomasz Przybył (FadeMind) - Monday, 30 May 2016, 10:21 GMT
2.02.154-2 did not fix issue.
[tomasz@arch ~]$ export LANG=C
[tomasz@arch ~]$ sudo systemctl daemon-reload
Failed to reload daemon: Connection timed out
[tomasz@arch ~]$ pacman -Q|grep lvm2
lvm2 2.02.154-2
[tomasz@arch ~]$ pacman -Q|grep systemd
libsystemd 230-3
systemd 230-3
systemd-kcm 1.2.1-2
systemd-sysvcompat 230-3



Only downgrade to 2.02-150-1 version and reboot works for now.

[tomasz@arch ~]$ pacman -Q|grep lvm2
lvm2 2.02.150-1
[tomasz@arch ~]$ hh
sudo systemctl daemon-reload
[tomasz@arch ~]$ sudo systemctl daemon-reload
[tomasz@arch ~]$
Comment by Jonathan Roemer (pid1) - Monday, 30 May 2016, 13:29 GMT Comment by Tom Yan (tom.ty89) - Monday, 30 May 2016, 14:35 GMT
@eworm, same here as FadeMind, still experiencing the issue with lvm2 2.02.154-2.

I even did `pacman -Rcs lvm2 device-mapper`, the issue is gone; and then `pacman -S cryptsetup` (which pulls back only device-mapper), the issue does not come up again; and then `pacman -S lvm2`, the issue comes up again.

EDIT: apparently you need to add this commit as well: https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=7fd4119d24eee55323e888dd78c70257d7c97a15
Comment by Christian Hesse (eworm) - Monday, 30 May 2016, 19:49 GMT
Ah, I missed the first part of the changes. We have lvm2 2.02.154-3 in [testing] now.
Comment by Tomasz Przybył (FadeMind) - Monday, 30 May 2016, 19:53 GMT
lvm2 2.02.154-3 solved issue. Thanks.

Loading...