Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49467 - [linux] 4.6.x Intel-pstate in kernel 4.6 has performance regressions

Attached to Project: Arch Linux
Opened by Alexander Pavel (SuperIce97) - Wednesday, 25 May 2016, 23:06 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 02 October 2017, 23:19 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description: Intel-pstate has major performance regressions in kernel 4.6. The kernel should not be updated until this is fixed to prevent major slowdowns on Intel based PCs. http://www.phoronix.com/scan.php?page=news_item&px=P-State-Possible-4.6-Regression


Additional info:
Kernel 4.6 (currently in testing)

Steps to reproduce:
CPU benchmark kernel 4.5 vs 4.6 on an Intel-based PC with the intel-pstate scaling driver.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 02 October 2017, 23:19 GMT
Reason for closing:  Not a bug
Additional comments about closing:  We have upgraded the kernel a number of times, even. If there are specific issues that can be fixed, report them upstream or ask upstream to recall a kernel release "because benchmarks omg".
Comment by Arup Roy Chowdhury (Arup) - Wednesday, 08 June 2016, 16:36 GMT
Installed 4.6 today with a Haswell i4790. With earlier kernels due to the config MHz=300 setting in Arch kernel, there would be no CPU scaling. Now with this kernel, its all normal like in SUSE and Ubuntu and Fedora kernels.

Loading...