Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49452 - [kwallet] Cannot open blowfish wallet with kwallet-5.22.0-2

Attached to Project: Arch Linux
Opened by Niccolò Belli (darkbasic) - Monday, 23 May 2016, 18:24 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 24 May 2016, 14:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

After upgrading from kwallet-5.22.0-1 to kwallet-5.22.0-2 I cannot open my blowfish wallet anymore. After rolling back the btrfs pacman transaction everything works flawlessly again.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 24 May 2016, 14:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  Brainfart, sorry.
Fixed in 5.22.0-3
Comment by Mickael Fontaine (M1CK431) - Monday, 23 May 2016, 21:28 GMT
Hi,

Same thing here.
It's very annoying when used with pam authentication to store SSH passphrase through SSH agent...

Can you please fix this issue quickly?
Thanks,
Comment by Antonio Rojas (arojas) - Monday, 23 May 2016, 22:46 GMT
Please comment on the upstream report giving as many details as you can (errors, logs...)

https://bugs.kde.org/show_bug.cgi?id=363451
Comment by DeLord (DeLord) - Tuesday, 24 May 2016, 00:05 GMT
Same problem here for me. I am looking into the upstream report asking about additional details, which haven't been asked for yet.
Comment by Urs Joss (ursus) - Tuesday, 24 May 2016, 03:44 GMT
Hi

Same here. Downgrade to kwallet-5.22.0-1 restored the correct behavior.

Thanks
Comment by Greg (misiunt) - Tuesday, 24 May 2016, 05:53 GMT
Same here. After succsessful login to the system the wallet remains closed and doesn't accept any passwords. Downgrading to 5.22.0-1 fixed it.
Comment by Mike Cloaked (mcloaked) - Tuesday, 24 May 2016, 09:39 GMT
On my system which uses an auto-opened wallet on login by deleting the wallet and re-creating a new one with the original name (kdewallet) the system does now seem to work - but with the original wallet it fails to open on login with the required lines in pam.d/sddm. However quite annoying having to delete the wallet and re-create it, and there should be a better solution - perhaps the upstream bug report will yield a fix.
Comment by Antonio Rojas (arojas) - Tuesday, 24 May 2016, 09:51 GMT
Does it work with 5.22.0-2 if you remove your KDE4 wallets from ~/.kde4/share/apps/kwallet/ ?
Comment by Antonio Rojas (arojas) - Tuesday, 24 May 2016, 10:20 GMT
Also, please xprop the password prompt window that you get and post the "WM_COMMAND(STRING)" line
Comment by Kamil (kamiox) - Tuesday, 24 May 2016, 10:59 GMT
I hit the same problem. I tried with the xprop but can't find "WM_COMMAND(STRING)" in the returned output.
Comment by Kamil (kamiox) - Tuesday, 24 May 2016, 11:02 GMT
Output from the xprop
Comment by Andrey (Andrey) - Tuesday, 24 May 2016, 14:21 GMT
I confirm this.
My partial solution is: downgrade to kwallet-5.22.0-1, run kwalletmanager5, open wallet, do export to XML, close kwalletmanager5, remove wallet (rm ~/.local/share/kwalletd/*), updgrade to kwallet-5.22.0-2, create new wallet, run kwalletmanager5, do import from XML. It works for me.

Loading...