Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49439 - [archlinux-appstream-data] information is out of date, providing tesseract-game

Attached to Project: Community Packages
Opened by Aleix Pol (apol) - Sunday, 22 May 2016, 23:52 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 24 May 2016, 14:17 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Appstream is reporting a game that isn't part of the repositories:
$ appstreamcli search tesseract
Identifier: tesseract.desktop [desktop]
Name: Tesseract
Summary: Smooth FPS with map editing, instagib, DM and CTF
Package: tesseract-game
Icon: tesseract-game_tesseract.png

This makes discover (master) crash because it makes PackageKit choke.

$ pacman -Ss tesseract-game
$

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 24 May 2016, 14:17 GMT
Reason for closing:  Upstream
Additional comments about closing:  Data is regenerated periodically, we currently don't have the resources to regenerate it every time a package is added/removed
Comment by Antonio Rojas (arojas) - Monday, 23 May 2016, 06:18 GMT
This should be handled in Discover not to crash in this situation. Packages are being removed all the time and regenerating the appstream metadata is an expensive operation, so there will be some missing packages most of the time.

Loading...