Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#49430 - [gnome-shell] Gnome fails launching after "pacman -Syu"

Attached to Project: Arch Linux
Opened by Flo (phoenix69) - Saturday, 21 May 2016, 17:33 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 28 July 2016, 20:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Hey there,

using Arch on Hyper-V (Windows 10) Gnome Desktop and Bootloader Grub. When I am using "pacman -Syu" to update my system the system every time goes into "boot loop" after restart. Have tried this mutliple times (because I am restoring snapshot before update). I sadly don't have the knowledge to figure out what is wrong with the update. see attached list of updates and failures. also boot screen.

Also it's not a classic boot loop it looks like arch is trying to start gnome but fails (deksop is flickering). This happens until like 1 minute until it remains in booting up (doing nothing)

What I did:
1) Launching TTY with CTRL+ALT+F2 works

2) Installed as many updates as possible manually.
Only 9 are left and one or more of them are the cause:

Pakete (9) clang-3.8.0-1 libevdev-1.5.1-1 libinput-1.3.0-2 llvm-libs-3.8.0-1
lvm2-2.02.150-1 mesa-11.2.2-1 mesa-libgl-11.2.2-1
xf86-input-evdev-2.10.2-1 xf86-input-libinput-0.19.0-1

3) did not update the linux kernel. (to execlude that failure). Didn't help

4) only downgrade gnome-shell. Didn't help.

Steps to reproduce:
Install Arch with Gnome in Hyper-V and: pacman -Syu

Pictures: Bootscreen (1) and Journalctl (2)

Files: Corfiles Gnome
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 28 July 2016, 20:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  Assuming this is fixed with new pkg releases.
Comment by Flo (phoenix69) - Saturday, 21 May 2016, 19:09 GMT
managed to get journalctl -b online (attached)
Comment by Flo (phoenix69) - Sunday, 22 May 2016, 08:00 GMT Comment by Jan Alexander Steffens (heftig) - Tuesday, 24 May 2016, 18:31 GMT
Please try getting traces from the latest shell core dump from coredumpctl.
Comment by Flo (phoenix69) - Tuesday, 24 May 2016, 19:07 GMT
coredumpctl info (lower=newer):

coredumpctl gdb gnome-session:

let me know if you need something else.
Comment by Flo (phoenix69) - Wednesday, 25 May 2016, 21:22 GMT
This seems to be an issue in every arch based distro, it affects also every GUI (Gnome, KDE, etc.)

Comment by Jan de Groot (JGC) - Thursday, 26 May 2016, 11:28 GMT
I don't think this is a bug in gnome-shell but rather llvm/mesa. The logs show SIGFPE (division by zero) and SIGILL.

SIGILL is probably fixed by this one:

There's probably more fixes for LLVM 3.8 in git master that are not in mesa 11.2.
Comment by Flo (phoenix69) - Wednesday, 08 June 2016, 14:16 GMT
Stil happening after pacman -Syu
Comment by Andreas Radke (AndyRTR) - Thursday, 28 July 2016, 07:35 GMT
We have new clang and mesa now in our repos. Has this been solved?