Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49352 - [st] DEL key doesnt work in weechat when using st

Attached to Project: Community Packages
Opened by ikohvei (ikohvei) - Monday, 16 May 2016, 05:33 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 15 August 2016, 11:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When using st, DEL key doesnt work in weechat (and other ncurses apps that use keypad mode).
st devs are not going to fix it because its actually a bad legacy behavior in xterm/urxvt.
Maybe the fix belongs as an aur pkg, st-delkey.

http://st.suckless.org/patches/delkey
http://st.suckless.org/patches/st-0.6-delkey.diff
http://git.suckless.org/st/tree/FAQ

---st---
% echo "$terminfo[dch1]" | cat -v
^[[P
% echo "$terminfo[kdch1]" | cat -v
^[[3~
% cat <(printf "$terminfo[smkx]"; cat -v)
^[[3~
% cat <(printf "$terminfo[rmkx]"; cat -v)
^[[P

---urxvt---
% echo "$terminfo[dch1]" | cat -v
^[[P
% echo "$terminfo[kdch1]" | cat -v
^[[3~
% cat <(printf "$terminfo[smkx]"; cat -v)
^[[3~
% cat <(printf "$terminfo[rmkx]"; cat -v)
^[[3~

This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 15 August 2016, 11:28 GMT
Reason for closing:  Won't fix
Comment by Andreas Radke (AndyRTR) - Monday, 16 May 2016, 07:41 GMT
I tend to "won't fix" or "not a bug". It's a design decision.

BTW: suckless packages always need to be patched and preconfigured in *.h to your needs. There's also scrolling missing and more.
Comment by ikohvei (ikohvei) - Monday, 16 May 2016, 21:14 GMT
That makes sense, but since it is a controversial design decisions that breaks compatibility with a large number of apps, and they even offer a patch on their website to fix it, I think it makes sense to find the patched version in the AUR.
Comment by Andreas Radke (AndyRTR) - Tuesday, 17 May 2016, 15:27 GMT

Loading...