Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49350 - [curl] Should depend on c-ares, or pacman may get broken

Attached to Project: Arch Linux
Opened by Chih-Hsuan Yen (yan12125) - Sunday, 15 May 2016, 21:24 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 15 May 2016, 21:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Today I remove wireshark-qt, and thus c-ares gets removed. Then pacman fails:

$ pacman
pacman: error while loading shared libraries: libcares.so.2: cannot open shared object file: No such file or directory

I have to extract libcares.so.2 from the package tarball and `sudo pacman -S c-ares --force` to make things work again.

Additional info:
core/pacman 5.0.1-3
core/curl 7.48.0-1
extra/c-ares 1.11.0-1

Steps to reproduce:
See above.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 15 May 2016, 21:40 GMT
Reason for closing:  Not a bug
Comment by Chih-Hsuan Yen (yan12125) - Sunday, 15 May 2016, 21:30 GMT
Well, I found I have a custom build of curl. Please close this ticket.

Loading...