Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49301 - [pitivi] Crash when trying to create a project

Attached to Project: Community Packages
Opened by Thom Wiggers (twiggers) - Wednesday, 11 May 2016, 19:11 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 02 July 2016, 04:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
pitivi crashes when trying to create a project.

Traceback (most recent call last):
File "/usr/lib/pitivi/python/pitivi/titleeditor.py", line 394, in tabSwitchedCb
self._connect_signals()
File "/usr/lib/pitivi/python/pitivi/titleeditor.py", line 326, in _connect_signals
self.app.gui.viewer.target.connect(
AttributeError: 'NoneType' object has no attribute 'viewer'
Traceback (most recent call last):
File "/usr/lib/pitivi/python/pitivi/application.py", line 259, in _newProjectLoadingCb
self._setScenarioFile(uri)
File "/usr/lib/pitivi/python/pitivi/application.py", line 254, in _setScenarioFile
content = project.read().replace("\n", "")
File "/usr/lib/python3.5/codecs.py", line 321, in decode
(result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa3 in position 4: invalid start byte
file:///home/thom/git/censorship/South.Park.S14E06.Uncensored.720p.WEBRip.AAC2.0.H.264.mkv:1: parser error : Start tag expected, '<' not found
Eߣ�B��B��B��B�B��matroskaB��B��S�g
^

(pitivi:9362): Gtk-WARNING **: Allocating size to GtkToggleToolButton 0x1d86b50 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(pitivi:9362): Gtk-WARNING **: Allocating size to GtkBox 0x1ebb3c0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(pitivi:9362): Gtk-WARNING **: Allocating size to pitivi+viewer+TransformationBox 0x1b8e2d0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(pitivi:9362): Gtk-WARNING **: Allocating size to pitivi+viewer+TransformationBox 0x1b8e2d0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
zsh: segmentation fault (core dumped) pitivi South.Park.S14E06.Uncensored.720p.WEBRip.AAC2.0.H.264.mkv

It looks like a python 2 vs python 3 unicode error.

Additional info:
* Package version 0.95-7
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 02 July 2016, 04:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  pitivi 0.96-1
Comment by Thom Wiggers (twiggers) - Wednesday, 11 May 2016, 19:13 GMT
The above trace was when I launched it from a folder that had mkv files, when I launch it from /tmp I get the following trace:

Traceback (most recent call last):
File "/usr/lib/pitivi/python/pitivi/titleeditor.py", line 394, in tabSwitchedCb
self._connect_signals()
File "/usr/lib/pitivi/python/pitivi/titleeditor.py", line 326, in _connect_signals
self.app.gui.viewer.target.connect(
AttributeError: 'NoneType' object has no attribute 'viewer'

(pitivi:9750): Gtk-WARNING **: Allocating size to GtkToggleToolButton 0x2dbbb50 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(pitivi:9750): Gtk-WARNING **: Allocating size to GtkBox 0x2e453c0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(pitivi:9750): Gtk-WARNING **: Allocating size to pitivi+viewer+TransformationBox 0x302c2d0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(pitivi:9750): Gtk-WARNING **: Allocating size to pitivi+viewer+TransformationBox 0x302c2d0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
zsh: segmentation fault (core dumped) pitivi
Comment by Luca (lukypie) - Sunday, 22 May 2016, 21:41 GMT
Same problem. I'm triying to install the git one.
Comment by Joonas Henriksson (ooo) - Saturday, 18 June 2016, 05:06 GMT
I just tested the latest git version, and the issue is indeed fixed upstream.
Quickly skimming trough the git log, this commit should fix the issue: https://git.gnome.org/browse/pitivi/commit/?id=62e5a852f905847e98cc653bc9e06fc8b57ab899

The commit failed to patch against 0.95, so I did my best backporting it.
Attached patch applies cleanly on 0.95 and fixes the segfault.

Loading...