Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49299 - [xf86-video-intel] 1:2.99.917+645+g88733a7-1 broke Firefox

Attached to Project: Arch Linux
Opened by c (c) - Wednesday, 11 May 2016, 13:31 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Wednesday, 25 May 2016, 20:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Since the update to xf86-video-intel 1:2.99.917+645+g88733a7-1, starting broke Firefox will mess up X in such a way that you have to switch to console and back to repair the corruption. Running Blink based browsers does not cause this.

Additional info:
* xf86-video-intel 1:2.99.917+645+g88733a7-1
* config and/or log files etc.


Steps to reproduce:
startx
firefox
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Wednesday, 25 May 2016, 20:30 GMT
Reason for closing:  Fixed
Comment by c (c) - Wednesday, 11 May 2016, 13:52 GMT
Downgrading to 1:2.99.917+641+ge4ef6e9-1 seems to fix it.
Comment by Andreas Radke (AndyRTR) - Wednesday, 11 May 2016, 18:43 GMT
please report it upstream...
Comment by Sharad (docbroke) - Friday, 13 May 2016, 04:27 GMT
additional info:

- in addition to above bug affects fonts display in terminal (not consol/VT) (tested with sakura & tilda), fonts are invisible when typed but appears after pressing "enter".
- bug also affects qutebrowser (qtwebkit based)
- after starting application like mpv or chromium, bug disappears ( until that application is in use), so one can use terminal/qutebrowser normally if mpv or chromium is running
- as posted above downgrading fixes the bug
Comment by Andreas Radke (AndyRTR) - Friday, 13 May 2016, 19:39 GMT
Still waiting for someones upstream bug report to follow.
Comment by MB (mrbougo) - Saturday, 14 May 2016, 11:47 GMT
I have a similar issue to that of Sharad (docbroke) with rxvt-unicode. It only occurs in TearFree mode. I reported it upstream: https://bugs.freedesktop.org/show_bug.cgi?id=95400
Comment by c (c) - Saturday, 21 May 2016, 11:33 GMT
1:2.99.917+654+ga508b11-1 seems to be fine. Testing over the weekend.
Comment by c (c) - Wednesday, 25 May 2016, 15:26 GMT
1:2.99.917+654+ga508b11-1 has been fine since Saturday.

Loading...