Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49290 - [steam] not compatible with libcrypt 1.7

Attached to Project: Community Packages
Opened by Michael (Zeth) - Tuesday, 10 May 2016, 18:24 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 10 May 2016, 18:27 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Seems like the recent update to multilib/lib32-libgcrypt 1.7.0-1 broke Steam

I've tested this different arch systems (one laptop with Antergos and Intel Graphics and one PC with AMD R7 graphics) with that version of libgcrypt.
Output is like:
libGL: dlopen /usr/lib32/xorg/modules/dri/radeonsi_dri.so failed (/usr/lib32/libgcrypt.so.20: symbol gpgrt_lock_lock, version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference)

Downgrading the said package is currently a workaround.

Steps to reproduce:
Update to latest lib32-libgcrypt and tun steam with LIBGL_DEBUG=verbose
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 10 May 2016, 18:27 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#48994 

Loading...