Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49261 - nfs-server.service fails to start on fresh install until reboot

Attached to Project: Arch Linux
Opened by Ian Kelling (IanKelling) - Sunday, 08 May 2016, 05:31 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 09 May 2016, 00:11 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Additional info:
* nfs-utils 1.3.3-3
* see logs below


Steps to reproduce:

On a fresh install with archlinux-2016.05.01-dual.iso,
I install a bunch of packages, then nfs, but it fails.
After I reboot, it works fine.

pacman -Sy nfs-utils
systemctl start rpcbind
systemctl start nfs-server


syslog output:

May 07 19:03:50 x2 systemd[1]: Starting Preprocess NFS configuration...
May 07 19:03:50 x2 systemd[1]: Reached target Host and Network Name Lookups.
May 07 19:03:50 x2 systemd[1]: Reached target RPC Port Mapper.
May 07 19:03:50 x2 systemd[1]: Starting GSSAPI Proxy Daemon...
May 07 19:03:50 x2 systemd[1]: Mounting NFSD configuration filesystem...
May 07 19:03:50 x2 systemd[1]: Mounting RPC Pipe File System...
May 07 19:03:50 x2 mount[11935]: mount: unknown filesystem type 'rpc_pipefs'
May 07 19:03:50 x2 mount[11933]: mount: unknown filesystem type 'nfsd'
May 07 19:03:50 x2 systemd[1]: Started Preprocess NFS configuration.
May 07 19:03:50 x2 systemd[1]: Started GSSAPI Proxy Daemon.
May 07 19:03:50 x2 systemd[1]: proc-fs-nfsd.mount: Mount process exited, code=exited status=32
May 07 19:03:50 x2 systemd[1]: Failed to mount NFSD configuration filesystem.
May 07 19:03:50 x2 systemd[1]: Dependency failed for NFS server and services.
May 07 19:03:50 x2 systemd[1]: Dependency failed for NFS Mount Daemon.
May 07 19:03:50 x2 sudo[11920]: pam_unix(sudo:session): session closed for user root
May 07 19:03:50 x2 systemd[1]: nfs-mountd.service: Job nfs-mountd.service/start failed with result 'dependency'.
May 07 19:03:50 x2 polkitd[5813]: Unregistered Authentication Agent for unix-process:11921:21618891 (system bus name :1.301, o
May 07 19:03:50 x2 systemd[1]: Dependency failed for NFSv4 ID-name mapping service.
May 07 19:03:50 x2 systemd[1]: nfs-idmapd.service: Job nfs-idmapd.service/start failed with result 'dependency'.
May 07 19:03:50 x2 systemd[1]: nfs-server.service: Job nfs-server.service/start failed with result 'dependency'.
May 07 19:03:50 x2 systemd[1]: proc-fs-nfsd.mount: Unit entered failed state.
May 07 19:03:50 x2 systemd[1]: var-lib-nfs-rpc_pipefs.mount: Mount process exited, code=exited status=32
May 07 19:03:50 x2 systemd[1]: Failed to mount RPC Pipe File System.
May 07 19:03:50 x2 systemd[1]: Dependency failed for RPC security service for NFS server.
May 07 19:03:50 x2 systemd[1]: rpc-svcgssd.service: Job rpc-svcgssd.service/start failed with result 'dependency'.
May 07 19:03:50 x2 systemd[1]: Dependency failed for RPC security service for NFS client and server.
May 07 19:03:50 x2 systemd[1]: rpc-gssd.service: Job rpc-gssd.service/start failed with result 'dependency'.
May 07 19:03:50 x2 systemd[1]: var-lib-nfs-rpc_pipefs.mount: Unit entered failed state.
May 07 19:03:50 x2 systemd[1]: Starting NFS status monitor for NFSv2/3 locking....
May 07 19:03:50 x2 systemd[1]: Starting Notify NFS peers of a restart...
May 07 19:03:50 x2 sm-notify[11955]: Version 1.3.3 starting
May 07 19:03:50 x2 rpc.statd[11960]: Version 1.3.3 starting
May 07 19:03:50 x2 rpc.statd[11960]: Flags: TI-RPC
May 07 19:03:50 x2 systemd[1]: Started Notify NFS peers of a restart.
May 07 19:03:50 x2 rpc.statd[11960]: Failed to read /var/lib/nfs/state: Success
May 07 19:03:50 x2 rpc.statd[11960]: Initializing NSM state
May 07 19:03:50 x2 rpc.statd[11960]: Running as root. chown /var/lib/nfs to choose different user
May 07 19:03:50 x2 systemd[1]: Started NFS status monitor for NFSv2/3 locking..



try to star it again, it fails again:



May 07 22:29:14 x2 sudo[12822]: ian : TTY=pts/0 ; PWD=/a ; USER=root ; COMMAND=/usr/bin/systemctl start nfs-server
May 07 22:29:14 x2 sudo[12822]: pam_unix(sudo:session): session opened for user root by ian(uid=0)
May 07 22:29:14 x2 polkitd[5813]: Registered Authentication Agent for unix-process:12823:22851292 (system bus name :1.309 [/usr/bin/pkttyagent --notify-fd 4 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
May 07 22:29:14 x2 systemd[1]: Mounting RPC Pipe File System...
May 07 22:29:14 x2 systemd[1]: Mounting NFSD configuration filesystem...
May 07 22:29:14 x2 mount[12829]: mount: unknown filesystem type 'rpc_pipefs'
May 07 22:29:14 x2 systemd[1]: var-lib-nfs-rpc_pipefs.mount: Mount process exited, code=exited status=32
May 07 22:29:14 x2 systemd[1]: Failed to mount RPC Pipe File System.
May 07 22:29:14 x2 systemd[1]: Dependency failed for NFSv4 ID-name mapping service.
May 07 22:29:14 x2 systemd[1]: nfs-idmapd.service: Job nfs-idmapd.service/start failed with result 'dependency'.
May 07 22:29:14 x2 systemd[1]: Dependency failed for RPC security service for NFS server.
May 07 22:29:14 x2 systemd[1]: rpc-svcgssd.service: Job rpc-svcgssd.service/start failed with result 'dependency'.
May 07 22:29:14 x2 systemd[1]: Dependency failed for RPC security service for NFS client and server.
May 07 22:29:14 x2 systemd[1]: rpc-gssd.service: Job rpc-gssd.service/start failed with result 'dependency'.
May 07 22:29:14 x2 systemd[1]: var-lib-nfs-rpc_pipefs.mount: Unit entered failed state.
May 07 22:29:14 x2 mount[12830]: mount: unknown filesystem type 'nfsd'
May 07 22:29:14 x2 systemd[1]: proc-fs-nfsd.mount: Mount process exited, code=exited status=32
May 07 22:29:14 x2 systemd[1]: Failed to mount NFSD configuration filesystem.
May 07 22:29:14 x2 systemd[1]: Dependency failed for NFS server and services.
May 07 22:29:14 x2 sudo[12822]: pam_unix(sudo:session): session closed for user root
May 07 22:29:14 x2 systemd[1]: Dependency failed for NFS Mount Daemon.
May 07 22:29:14 x2 polkitd[5813]: Unregistered Authentication Agent for unix-process:12823:22851292 (system bus name :1.309, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
May 07 22:29:14 x2 systemd[1]: nfs-mountd.service: Job nfs-mountd.service/start failed with result 'dependency'.
May 07 22:29:14 x2 systemd[1]: nfs-server.service: Job nfs-server.service/start failed with result 'dependency'.
May 07 22:29:14 x2 systemd[1]: proc-fs-nfsd.mount: Unit entered failed state.
May 07 22:29:14 x2 systemd[1]: Starting Notify NFS peers of a restart...
May 07 22:29:14 x2 sm-notify[12846]: Version 1.3.3 starting
May 07 22:29:14 x2 sm-notify[12846]: Already notifying clients; Exiting!
May 07 22:29:14 x2 systemd[1]: Started Notify NFS peers of a restart.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 09 May 2016, 00:11 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Expected behavior when the current kernel's modules are not available.
Comment by Doug Newgard (Scimmia) - Sunday, 08 May 2016, 14:07 GMT
Sounds to me like you had updated the kernel without rebooting.
Comment by Ian Kelling (IanKelling) - Sunday, 08 May 2016, 15:45 GMT
Yup. That is correct. I'll do another install within the next few hours to confirm that fixes it.

Loading...