Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49170 - [meld] Does not work with "Global dark theme"

Attached to Project: Arch Linux
Opened by Matthew Prenger (matthewprenger) - Sunday, 01 May 2016, 21:26 GMT
Last edited by Jan de Groot (JGC) - Friday, 10 June 2016, 11:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Recently Meld seems to be crashing when doing a directory compare with "Couldn't find colour scheme details for meld:unknown-text-foreground; this is a bad install"
I have tried re-installing meld, removing all of it's configuration files, and resetting the values in dconf-editor to the defaults with no luck. Looking in the journal I don't see any other log messages than the one line above.


Additional info:
* package version(s)
Meld 3.16.0
Gnome-shell 3.20.1
GTK3 3.20.3
Default Adwatia (dark mode) theme

* config and/or log files etc.

"Couldn't find colour scheme details for meld:unknown-text-foreground; this is a bad install"


Steps to reproduce:
Choose two directories to compare and click compare. The application will crash.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 10 June 2016, 11:58 GMT
Reason for closing:  Fixed
Comment by Matthew Prenger (matthewprenger) - Sunday, 01 May 2016, 21:28 GMT
Whoops. Sorry about the title, didn't notice until after I hit sumbit. I can't find an edit button now to change it.
Comment by Doug Newgard (Scimmia) - Sunday, 01 May 2016, 21:40 GMT
Works fine here. Make sure to try with the regular Adwaita theme.
Comment by Matthew Prenger (matthewprenger) - Sunday, 01 May 2016, 21:45 GMT
Ahh turning the "Global dark theme" off fixes the problem. Is this still a meld bug, or should I report this with someone else?
Comment by Doug Newgard (Scimmia) - Monday, 02 May 2016, 14:10 GMT
It's likely a problem with the theme. I don't know what "global dark theme" does, does it use a variant of Adwaita? If so, were is it from?
Comment by Matthew Prenger (matthewprenger) - Monday, 02 May 2016, 16:06 GMT
It's a toggle switch in the gnome-tweak-tool (see screenshot attached). I don't know much about how GTK themes work, but I assume it just flips to Adwaita's dark version (which is available out of the box with gnome installed).
Comment by Mark Blakeney (bulletmark) - Friday, 10 June 2016, 03:47 GMT
Note there is a simple fix for this problem at https://bugs.launchpad.net/ubuntu/+source/meld/+bug/1580366.

Loading...