Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49167 - [plasma-workspace] Right clicking on legacy icons in the does not give a menu

Attached to Project: Arch Linux
Opened by Luca (lukypie) - Sunday, 01 May 2016, 18:32 GMT
Last edited by Antonio Rojas (arojas) - Friday, 24 February 2017, 10:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: I have a couple of gtk+ programs (pamac, redshift) that have a GTK icon tray.
On plasma 5, when I click on them on the plasma icon tray, nothing happens.

There should be a dropdown menu after clicking on them
Nothing happens
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 24 February 2017, 10:23 GMT
Reason for closing:  No response
Comment by Doug Newgard (Scimmia) - Sunday, 01 May 2016, 21:22 GMT
It works on some, but not on others. It's been this way since xembedsniproxy was separate.
Comment by Luca (lukypie) - Sunday, 22 May 2016, 21:17 GMT
Is there a workaround yet?
Comment by Carlos jimenez (ozmage) - Wednesday, 01 February 2017, 07:27 GMT
this is happening to me too on kde plasma 5.9 there is no way to fix this or get a workaround this ?
Comment by Carlos jimenez (ozmage) - Wednesday, 01 February 2017, 17:45 GMT
This Work On Kde Neon Without Problems why is not working on arch ? on Plasma 5.9
Comment by Antonio Rojas (arojas) - Thursday, 02 February 2017, 00:29 GMT
what works on neon and not on arch?
Comment by Carlos jimenez (ozmage) - Thursday, 02 February 2017, 21:46 GMT
The Gtk Apps Tray Icons Works On Kde Neon Rigth and left clicks of the mouse works showing menus and minimaxing and maximazing etc they just works like on any gtk desktop for example blueman on kde plasma 5.9 on arch does nothing and uget nothing and hexchat only minimizes and maximazes and dekuge does the same as hexchat , pamac-tray shows but does nothing
Comment by Antonio Rojas (arojas) - Tuesday, 14 February 2017, 18:07 GMT
@ozmage your issue is a different one and should be fixed in 5.9.2 (and yes, it also affected Neon since it's an upstream issue).

@luckypie is your problem still reproducible with recent Plasma?

Loading...