Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49160 - [networkmanager] 1.2.0-2 broke Wi-Fi connection

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Sunday, 01 May 2016, 08:02 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 25 February 2022, 16:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

NetworkManager 1.2.0-2 switched the default DHCP client from "dhclient" to "internal". Unfortunately the internal DHCP client doesn't work, it just times out (and there is no useful information in the log that I can see). dhclient on the other hand connects almost immediately. So do an Ubuntu box, a Windows 10 machine, an Android phone, a Macbook ... so I tend the think the problem is not the access point.

Additional info:
* package version(s)

networkmanager 1.2.0-3
dhclient 4.3.4-2

* config and/or log files etc.

May 01 03:41:58 pandorica NetworkManager[388]: <info> [1462088518.8952] dhcp4 (wlp2s0): activation: beginning transaction (timeout in 45 seconds)
May 01 03:42:01 pandorica NetworkManager[388]: <info> [1462088521.1962] dhcp6 (wlp2s0): activation: beginning transaction (timeout in 45 seconds)
May 01 03:42:02 pandorica NetworkManager[388]: <info> [1462088522.4550] address 2602:306:bcb4:a100::3ef/128 lft 2592000sec pref 604800sec lifetime 9-9[604800,2592000] src dhcp
May 01 03:42:02 pandorica NetworkManager[388]: <info> [1462088522.4550] nameserver 2602:306:bcb4:a100::1
May 01 03:42:02 pandorica NetworkManager[388]: <info> [1462088522.4550] dhcp6 (wlp2s0): state changed unknown -> bound
May 01 03:42:44 pandorica NetworkManager[388]: <warn> [1462088564.1413] dhcp4 (wlp2s0): request timed out
May 01 03:42:44 pandorica NetworkManager[388]: <info> [1462088564.1413] dhcp4 (wlp2s0): state changed unknown -> timeout
May 01 03:42:44 pandorica NetworkManager[388]: <info> [1462088564.1546] dhcp4 (wlp2s0): canceled DHCP transaction
May 01 03:42:44 pandorica NetworkManager[388]: <info> [1462088564.1546] dhcp4 (wlp2s0): state changed timeout -> done

Steps to reproduce:

Try to connect to Wi-Fi.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 25 February 2022, 16:43 GMT
Reason for closing:  Deferred
Comment by Kerr (zefkerrigan) - Sunday, 01 May 2016, 13:57 GMT
Hi!
I have a same problem after upgrade to networkmanager 1.2.0-3.
I was tested it on three diferent computers and on all computers i have same problem.
Downgrade to networkmanager-1.1.94-1 solve this promlem.
This problem is not with wi-fi only. Networkmanager 1.2.0-3 cant't to connect by cable.
Comment by Doug Newgard (Scimmia) - Sunday, 01 May 2016, 14:08 GMT
If you want to use dhclient, use dhclient. No need to be "waiting for a fix".
Comment by Joni Hyttinen (johy) - Wednesday, 04 May 2016, 16:17 GMT
The switch to dhcp=internal in NetworkManager.conf causes the NetworkManager.service to restart constantly as the internal dhcp causes assertion failures.
The previous dhcp=dhclient works fine.

touko 04 18:41:39 Overwatch-Nexus systemd[1]: Starting Network Manager...
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.4996] NetworkManager (version 1.2.0) is starting...
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.4997] Read config: /etc/NetworkManager/NetworkManager.conf
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.5043] manager[0x28a21d0]: monitoring kernel firmware directory '/usr/lib/firmware'.
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.5078] dns-mgr[0x28b48a0]: set resolv-conf-mode: default
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.5078] dns-mgr[0x28b48a0]: using resolv.conf manager 'resolvconf'
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.5089] WiFi hardware radio set enabled
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.5089] WWAN hardware radio set enabled
touko 04 18:41:39 Overwatch-Nexus systemd[1]: Started Network Manager.
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.5366] settings: loaded plugin keyfile: (c) 2007 - 2015 Red Hat, Inc. To report bugs please use the NetworkManager mailing list.
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.5475] keyfile: new connection /etc/NetworkManager/system-connections/Uusi 802-3-ethernet-yhteys (4b9fada8-97b3-4968-86cc-c3e94e5fd64a,"Verkkokaapeli")
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6320] settings: hostname: using hostnamed
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6320] settings: hostname changed from (none) to "Overwatch-Nexus"
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6323] Using DHCP client 'internal'
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6323] manager: WiFi enabled by radio killswitch; enabled by state file
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6324] manager: WWAN enabled by radio killswitch; enabled by state file
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6324] manager: Networking is enabled by state file
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6325] Loaded device plugin: NMVxlanFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6326] Loaded device plugin: NMVlanFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6326] Loaded device plugin: NMVethFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6327] Loaded device plugin: NMTunFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6327] Loaded device plugin: NMMacvlanFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6327] Loaded device plugin: NMIPTunnelFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6328] Loaded device plugin: NMInfinibandFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6328] Loaded device plugin: NMEthernetFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6329] Loaded device plugin: NMBridgeFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6329] Loaded device plugin: NMBondFactory (internal)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6338] Loaded device plugin: NMAtmManager (/usr/lib/NetworkManager/libnm-device-plugin-adsl.so)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6363] Loaded device plugin: NMWwanFactory (/usr/lib/NetworkManager/libnm-device-plugin-wwan.so)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6366] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/libnm-device-plugin-bluetooth.so)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6370] Loaded device plugin: NMWifiFactory (/usr/lib/NetworkManager/libnm-device-plugin-wifi.so)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6432] Loaded device plugin: NMTeamFactory (/usr/lib/NetworkManager/libnm-device-plugin-team.so)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6441] device (enp4s0): link connected
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6451] manager: (enp4s0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/0)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6471] dns-mgr: Writing DNS information to /usr/bin/resolvconf
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6740] manager: (enp4s0): found matching connection 'Verkkokaapeli'
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6741] device (enp4s0): state change: unmanaged -> unavailable (reason 'connection-assumed') [10 20 41]
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6744] device (enp4s0): state change: unavailable -> disconnected (reason 'connection-assumed') [20 30 41]
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6756] device (enp4s0): Activation: starting connection 'Verkkokaapeli' (4b9fada8-97b3-4968-86cc-c3e94e5fd64a)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6759] device (lo): link connected
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6768] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6871] manager: startup complete
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6875] device (enp4s0): state change: disconnected -> prepare (reason 'none') [30 40 0]
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6883] policy: set 'Verkkokaapeli' (enp4s0) as default for IPv4 routing and DNS
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6890] policy: set 'Verkkokaapeli' (enp4s0) as default for IPv6 routing and DNS
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6905] device (enp4s0): state change: prepare -> config (reason 'none') [40 50 0]
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6913] device (enp4s0): state change: config -> ip-config (reason 'none') [50 70 0]
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.6919] dhcp4 (enp4s0): activation: beginning transaction (timeout in 45 seconds)
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7293] address 192.168.10.10
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7293] plen 24
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7294] expires in 86400 seconds
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7294] nameserver '192.168.10.1'
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7294] domain name 'home'
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7294] hostname 'Overwatch-Nexus'
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7294] gateway 192.168.10.1
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7299] dhcp4 (enp4s0): state changed unknown -> bound
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7457] device (enp4s0): state change: ip-config -> ip-check (reason 'none') [70 80 0]
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7464] device (enp4s0): state change: ip-check -> secondaries (reason 'none') [80 90 0]
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7466] device (enp4s0): state change: secondaries -> activated (reason 'none') [90 100 0]
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7467] manager: NetworkManager state is now CONNECTED_GLOBAL
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7468] manager: NetworkManager state is now CONNECTED_SITE
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7468] manager: NetworkManager state is now CONNECTED_GLOBAL
touko 04 18:41:39 Overwatch-Nexus NetworkManager[4451]: <info> [1462376499.7480] device (enp4s0): Activation: successful, device activated.
touko 04 18:41:40 Overwatch-Nexus NetworkManager[4451]: <info> [1462376500.4372] dhcp6 (enp4s0): activation: beginning transaction (timeout in 45 seconds)
touko 04 18:41:40 Overwatch-Nexus NetworkManager[4451]: **
touko 04 18:41:40 Overwatch-Nexus NetworkManager[4451]: NetworkManager:ERROR:dhcp-manager/nm-dhcp-client.c:301:nm_dhcp_client_set_state: assertion failed (g_hash_table_size (options) > 0): (0 > 0)
touko 04 18:41:40 Overwatch-Nexus systemd[1]: NetworkManager.service: Main process exited, code=dumped, status=6/ABRT
touko 04 18:41:40 Overwatch-Nexus systemd[1]: NetworkManager.service: Unit entered failed state.
touko 04 18:41:40 Overwatch-Nexus systemd[1]: NetworkManager.service: Failed with result 'core-dump'.
touko 04 18:41:40 Overwatch-Nexus systemd[1]: NetworkManager.service: Service hold-off time over, scheduling restart.
touko 04 18:41:40 Overwatch-Nexus systemd[1]: Stopped Network Manager.
touko 04 18:41:40 Overwatch-Nexus systemd[1]: Starting Network Manager...

This was with versions
networkmanager 1.2.0-3
dhclient 4.3.4-2
Comment by Jean-Patrick Guerrero (kilbith) - Wednesday, 04 May 2016, 17:58 GMT
Same issue here.
Comment by Odin Hørthe Omdal (velmont) - Friday, 10 June 2016, 09:20 GMT
It took me a long while to figure out what was wrong here. Primarily because I thought the wifi router was bad, so I didn't investigate. One month of no wifi connection at home before I finally had a look. (well, my fault, but ohwell).


I don't see a reason for this change, the default should not be set to something that will fail on some routers just to be able to remove a dependency. Especially when upstream itself primarily wants dhclient to work.

If you don't set this option, it will try dhclient first, and then fall back to internal if it doesn't work. This seems to be the fix for this issue, just remove the setting.

https://git.archlinux.org/svntogit/packages.git/commit/trunk/NetworkManager.conf?h=packages/networkmanager&id=e467359d8ab26d47e680694e0689f48d74a7de0c
Comment by Alexander Maznev (pik) - Tuesday, 04 October 2016, 14:11 GMT
> If you don't set this option, it will try dhclient first, and then fall back to internal if it doesn't work. This seems to be the fix for this issue, just remove the setting.

How is a core-dump a reasonable thing in an commonly used package? Has this been filed upstream?
Comment by Alexander Maznev (pik) - Wednesday, 05 October 2016, 14:09 GMT
> If you don't set this option, it will try dhclient first, and then fall back to internal if it doesn't work. This seems to be the fix for this issue, just remove the setting.

How is a core-dump a reasonable thing in an commonly used package? Has this been filed upstream?
Comment by Odin Hørthe Omdal (velmont) - Wednesday, 05 October 2016, 14:21 GMT
No need to repeat yourself.

And yes, it is reported upstream. I had a fix, but I found out it was bad, and I don't think anyone picked it up after that.

https://github.com/systemd/systemd/pull/3509

If someone else can follow up and test, that'd be awesome. I've since upgraded my router, because it is shitty in many ways. I might have it stored somewhere so maybe I can debug further to help them fix the bug properly.
Comment by mattia (nTia89) - Friday, 25 February 2022, 16:09 GMT
Is this issue still valid?
Comment by John Lindgren (jlindgren) - Friday, 25 February 2022, 16:40 GMT
It is >5 years old, and I don't have the same access point to test with any more. Let's close it.

Loading...