Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#49157 - [linux] No sound after plugging in headphones (GNOME) restart gives you Dummy Output

Attached to Project: Arch Linux
Opened by andrewtramutolo (andrewtramutolo) - Saturday, 30 April 2016, 21:53 GMT
Last edited by Thomas B├Ąchler (brain0) - Saturday, 30 July 2016, 12:21 GMT
Task Type Bug Report
Category Kernel
Status Assigned
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 6
Private No


Description: No sound after plugging in headphones GNOME, restart gives you dummy output. I have already tried:

Unmuting every channel in alsamixer
Adding my username in the audio group

Additional info:

aplay -l (before restart)
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3266 Analog [ALC3266 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

aplay -l (after restart)
no soundcards...

Dell XPS 15" 9550
Chip: Realtek ALC3266
Card: HDA Intel PCH

Steps to reproduce:

1) Plug in headphones or speakers
2) Select headphones in GNOME pop up window
3) No sound from either headphones or internal speakers, even after unplugging headphones.
4) Restart gives you Dummy Output, and no sound comes from either speakers/headphone until you restart about 5 times.

If you need any more information please ask. I am still a Arch noob.
This task depends upon

Comment by andrewtramutolo (andrewtramutolo) - Thursday, 05 May 2016, 13:49 GMT
Update: I had created a temporary "fix" solution here:

This is from me experimenting with different solutions.

Attached is a log journalctl | grep snd_hda while I was fixing it. I currently have sound through my headphones and speakers, but I have to restart my laptop every time I want to switch. I do not know if it is going to go back to Dummy Output but it seems to be better then it was.
Comment by Silas Davis (silasdavis) - Friday, 03 June 2016, 15:03 GMT
I think I am seeing a variant of this on identical hardware (XPS 15 9550 with ALC3266).

For me when I boot the card is detected (as with aplay -l) but the only output I can see is the HDMI / DisplayPort 2 (unplugged) in pavucontrol. Even though HDMI is not connected which never used to be the case. If I plug some headphones then my internal speakers and the headphones appear as outputs (and remain). However the internal microphone never appears (nor do any inputs).

Not quite sure when this happened but it must have been in the last week or so, but it's possible I didn't notice because I may have resolved the output issue by plugging in a jack. It's only now I've come round to use the microphone that I realise it's gone.

Perhaps we should be reporting this upstream, but not sure where to. Is this likely to be a kernel change?
Comment by andrewtramutolo (andrewtramutolo) - Friday, 03 June 2016, 15:10 GMT
silasdavis: Everytime I reinstall Arch, it would take a few days for this bug to present in the OS.

I'm honestly not too sure what type of bug this is: kernel, GNOME, or whatever else there is. I'm unfamiliar with reporting bugs to upstream because I'm still a beginner when it comes to Linux in general. But I'm more than happy to help get this resolved as it's still driving me nuts. I have to restart my PC everytime I plug in headphones. Now I'm too afraid to use the microphone as it will probably "Dummy Output" again :#
Comment by Silas Davis (silasdavis) - Friday, 03 June 2016, 17:56 GMT
I can help on one count: it's not GNOME. I suspect it's a kernel bug, i.e. the kernel module snd-hda-intel. I tried downgrading to linux-4.5.3, which didn't help. It could be with also

I do have a dual boot with windows, and there seems to be some possibility that windows messes with it:, but that avenue hasn't helped.

But that does make me wonder if it is a device state thing. I might try from a live CD. Are you using pulseaudio? Do you see the unplugged HDMI as an output?

Comment by andrewtramutolo (andrewtramutolo) - Friday, 03 June 2016, 18:26 GMT
I can attest that Windows is not the culprit. I am running bootctl exclusively for my Arch installation. It could also add to this bug but I don't believe is the root cause. I am in fact using PulseAudio.

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3266 Analog [ALC3266 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

To add to your previous comment about input devices, when I select a different Input device with headphones plugged in, I get output in both the headphones and internal laptop speakers.

GNOME only shows Speakers and Headphones in the GUI interface.

Comment by andrewtramutolo (andrewtramutolo) - Friday, 03 June 2016, 19:32 GMT
After changing inputs in GNOME, I restarted and received Dummy Output. I tried all my solutions but nothing works. I am now getting this at startup:

Jun 03 15:28:06 {name{ kernel: snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Jun 03 15:28:07 {name} kernel: snd_hda_intel 0000:00:1f.3: CORB reset timeout#1, CORBRP = 0
Jun 03 15:28:07 {name} kernel: snd_hda_intel 0000:00:1f.3: no codecs found!
Comment by andrewtramutolo (andrewtramutolo) - Sunday, 12 June 2016, 20:36 GMT
To add to the temporary list of fixes:

- Disable audio, microphone, and internal speaker from BIOS, let it boot into Arch, shutdown, re-enable audio settings, and boot into Arch with sound back. This has worked 100% of the time... so far.
Comment by Whitley Striber (WhitleyStriber) - Monday, 08 August 2016, 14:28 GMT
When I changed video drivers, the problem seemed to morph into a different problem.

When I use nouveau/intel with bumblebee, it seems that plugging headphones in constantly works like it should. Headphones show up as headphones and the computer seems to recognize both. BUT... there is no sound from the headphones, even after a restart. I am starting to believe that this is an issue with either the nvidia driver, or bumblebee/optimus. I think I had read in the past that the sound is conflicting with the HDMI port or something like that. I reverted back to nvidia due to compatibility issues with nouveau (or I'm just not reading all the necessary documentation) and this original problem came back.
Comment by Tyler Foo (ghfujianbin) - Monday, 19 September 2016, 07:12 GMT
Having the same issue with HDA Intel PCH here on Gnome. My workaround for now is to just power off the computer and turn it back on again. Headphone jack should work after that until it suddenly stops working again.
Comment by Whitley Striber (WhitleyStriber) - Tuesday, 20 September 2016, 14:06 GMT
To update this thread, I found out that GNOME somehow makes the matter worse. The issue does carry over to i3wm. A workaround a user submitted to the Dell XPS wiki is to put your computer to sleep, then wake it up. (Assuming it doesn't restart your computer, ANOTHER bug stated in the Dell XPS Arch wiki)
Comment by Andrea Agosti (cifvts) - Tuesday, 18 July 2017, 07:01 GMT
I'm stuck with the very same bug and any "workaround" so far didn't worked. Is a bug open in the Linux Kernel project? This bug report is the most complete so far, and the only one open (Fedora closed it as WORKSFORME...).
I have a dell 5580, audio worked till some point were it stopped and I have those 3 lines in dmesg
Comment by Merrick Luo (merrickluo) - Friday, 17 November 2017, 13:05 GMT
I think this might be related to pulseaudio? I can plug/unplug headphone without problem after disable pulseaudio.service & pulseaudio.socket
Comment by Mads (Mads) - Monday, 16 July 2018, 08:11 GMT
If you compile i915 as a kernel built-in instead of a module, then this issue disappears, at least on my computer. I can only guess it has something to do with the gpu setting up power-related stuff that somehow affects sound, making it important that i915 loads before the hda stuff...

If you want i915 in-kernel, you must remember to include the firmware files in the kernel binary. From 4.18 rc:

[drm] Finished loading DMC firmware i915/skl_dmc_ver1_27.bin (v1.27)
[drm] HuC: Loaded firmware i915/skl_huc_ver01_07_1398.bin (version 1.7)
[drm] GuC: Loaded firmware i915/skl_guc_ver9_33.bin (version 9.33)
Comment by David Rosenstrauch (darose) - Friday, 24 August 2018, 18:55 GMT
I'm suffering from this issue too, and it's a huge nuisance. (Suspending every time I want to listen to headphones is not a workable solution.)

Given the findings @Mads reported about running i915 as a kernel built-in so that it loads first, I'm wondering if booting with earlymodules=i915 is a solution as well. Going to test that out shortly.

BTW, does anyone know if there's an upstream kernel bug report open for this issue? It seems like it's been an issue reported on several distros (see and has been open for over 2 years. If there's an upstream bug report, I'd like to track it.
Comment by David Rosenstrauch (darose) - Wednesday, 07 November 2018, 21:19 GMT Comment by mattia (nTia89) - Sunday, 27 February 2022, 08:34 GMT
I suffered of a similar issue years ago, with a similar hardware/software configuration (Dell XPS 9343 + GNOME)
but it has been fixed years ago.
(...honestly I do not know if it was a software problem (GNOME), a kernel problem or even a mix of the former two...)

Is it still valid for you?