Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#49142 - [networkmanager-openvpn] not working after upgrade

Attached to Project: Arch Linux
Opened by Jaroslaw Siebert (y0g1) - Friday, 29 April 2016, 19:59 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 29 April 2016, 22:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 5
Private No



After networkvpn-openvpn upgrade from 2016-04-29 the openvpn connection stopped working.

Additional info:
* package version(s) networkmanager-openvpn-1.2.0-1
* config and/or log files etc.
NetworkManager[2772]: <warn> [1461959930.1094] vpn-connection[0x9d41f0,36252628-ee5b-4f41-bd48-7d4263394065,"OpenvpnHost",15:(tun0)]: VPN connection: did not receive valid IP config information
nm-openvpn-Message: openvpn[5908]: send SIGTERM
nm-openvpn-Message: wait for 1 openvpn processes to terminate...

Steps to reproduce:
This task depends upon

Comment by Turbo (Reanoyer) - Sunday, 01 May 2016, 07:37 GMT
Are you using network-manager-applet? It and Networkmanager (up-to-dated-version) brokes me

A downgrade worked for me, now I'm waiting for a fix
Comment by Mike Ambrose (paco3346) - Wednesday, 04 May 2016, 14:18 GMT
I'm having a similar issue but with openconnect (after updating to networkmanager-1.2.0-3).

I get a similar message in the logs:

May 04 10:02:33 mambrose-arch NetworkManager[2340]: <warn> [1462370553.8050] vpn-connection[0x12ff3e0,4eea8755-6d16-49bf-b6f1-a63d58eaf23e,"USS",4:(vpn0)]: VPN connection: did not receive valid IP config information

If I remove manually specified routes the VPN gets set up properly.
Reverting to networkmanager-1.0.12-1 fixed the issue for now.
Comment by Jaroslaw Siebert (y0g1) - Wednesday, 04 May 2016, 20:15 GMT
I removed the old vpn setup from networkmanager and created new one.
It is working ok now. What is strange - the parameters in old config was not "0" but very huge number.
Comment by Yaroslav Zenin (kiotoze) - Monday, 16 May 2016, 22:27 GMT
> Jaroslaw Siebert
I also tried to delete old config and create new one but it does not help
Temporary switch back to previous version
Comment by Yaroslav Zenin (kiotoze) - Monday, 16 May 2016, 22:28 GMT
Maybe anyone can help how to debug networkmanager-openvpn to check what exactly happened?
Comment by Infanta Xavier (xavier83) - Monday, 22 August 2016, 08:27 GMT
My config file doesn't have lzo compression turned on, but when importing it gets turned on by default, and even after disabling it in settings,
I get the following errors in journalctl.

Aug 22 13:49:52 medusa nm-openvpn[9970]: WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1544', remote='link-mtu 1543'
Aug 22 13:49:52 medusa nm-openvpn[9970]: WARNING: 'comp-lzo' is present in local config but missing in remote config, local='comp-lzo'
Aug 22 13:53:17 medusa nm-openvpn[9970]: Bad LZO decompression header byte: 42
Comment by Arvid Warnecke (nostalgix) - Thursday, 27 April 2017, 05:20 GMT
I downgraded the openvpn and the libnm and networkmanager packages yesterday to get back into the office vpn after it broke by the latest updates.
I got the message, that my crt file is not readable - which did not change at all.
EDIT: Just noticed that this bug is already open for almost a year and only seems to be about similar problems... As I am not able to delete this comment, maybe it's worth to look into the actual issues I noticed since update to 2.4.1-2. 2.4.1-1 worked well.