AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#49134 - AUR site search includes packages' keywords when searching by name and description

Attached to Project: AUR web interface
Opened by Igor (f2404) - Friday, 29 April 2016, 10:27 GMT
Last edited by Lukas Fleischer (lfleischer) - Sunday, 05 November 2017, 18:47 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 4.2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

"client git" search results (https://aur.archlinux.org/packages/?O=300&SeB=nd&K=client+git&SB=n&SO=a&PP=50&do_Search=Go) include one package that does not have "client" within its name or description: https://aur.archlinux.org/packages/tinc-pre-git/
But it does have "client" among its keywords, so it seems that the search is performed by keywords as well which I think is a bug.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Sunday, 05 November 2017, 18:47 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Friday, 23 December 2016, 22:50 GMT
Sounds more like "by design" to me. What is the point of keywords if the search doesn't cover them?
Comment by Igor (f2404) - Saturday, 24 December 2016, 07:14 GMT
There's a separate search option for keywords.
This particular option is called "Name, Description", and I believe it shouldn't search by any fields other than name and description.
Comment by Doug Newgard (Scimmia) - Sunday, 25 December 2016, 14:16 GMT
So a fix here would be changing the wording of the option?
Comment by Igor (f2404) - Sunday, 25 December 2016, 14:31 GMT
Well, if current behavior is desired, then I think the answer would be yes.
Comment by Sun (nodivbyzero) - Monday, 02 January 2017, 06:01 GMT Comment by Lukas Fleischer (lfleischer) - Sunday, 05 November 2017, 18:47 GMT
Yes, this is by design...

Loading...