Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#490 - w3m errors soloved by removing the --disable-mouse parameter

Attached to Project: Arch Linux
Opened by Scott Robbins (scottro111) - Saturday, 28 February 2004, 03:16 GMT
Last edited by dorphell (dorphell) - Saturday, 28 February 2004, 06:15 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To dorphell (dorphell)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.6 Widget
Due in Version Undecided
Due Date Undecided
Percent Complete 80%
Votes 0
Private No

Details

There are two problems with the existing w3m package.
Firstly, gpm is not listed as a dependency. However, if w3m is installed without gpm then one receives the error, upon trying to open a web page with w3m of:

w3m: error while loading shared libraries: libgpm.so.1: cannot open shared object file: No such file or directory.

If one installs gpm w3m will then open. However, one will find the top of the page covered with messages such as

***debug [lib/libow.c(204)]:
VC:0
VC: 0mp/isdigit/option/consolename failed
Oh, oh, it's an error! possible I die.

This problem is fixed if one includes the -no-mouse option when calling w3m. (This bug was up here before, but a search seems to indicate it's no longer here.)

Doing a little experimentation indicates that if one removes the --disable-mouse parameter, the problem disappears. I am not a programmer and don't know the cause
one way or another, but it seems that leaving out the --disable-mouse option fixes the problem

Scott
This task depends upon

Closed by  dorphell (dorphell)
Saturday, 28 February 2004, 16:25 GMT
Reason for closing:  Not a bug
Comment by dorphell (dorphell) - Saturday, 28 February 2004, 06:10 GMT
That does not fix the problem, it merely does so on your local build. As I said the last time you opened on this issue, it's gpm's bug not w3m, though I am surprised that --disable-mouse stills puts that out for you, it fixed it for me and everyone else that complained. Did you build it yourself? The configure script is likely to screw you over even if you say --disable mouse. I've built w3m with gpm 100% off my system so there's no way it was linked to it. I'll do it again just to make sure, maybe I just did --disable-mouse.
Comment by Scott Robbins (scottro111) - Saturday, 28 February 2004, 14:51 GMT
I had run into the issue previously, however, as you say, only on this local machine. I ~had~ had the problem on another machine as well, however, I just tried uninstalling w3m and gpm, and reinstalling w3m and everything worked.

Thanks for your quick response on this.

Loading...