Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49068 - [gzip] Regression with -l output to pipes

Attached to Project: Arch Linux
Opened by nan (someonerandom) - Sunday, 24 April 2016, 12:33 GMT
Last edited by Sébastien Luttringer (seblu) - Tuesday, 26 April 2016, 16:31 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

gzip 1.7 has introduced a regression with -l output to pipes.

http://git.savannah.gnu.org/cgit/gzip.git/commit/?id=3557cd57906915eb9c990b5f386e25c395592643

This patch should be included into 1.7-2 because -l isn't working with 1.7-1 anymore.

Additional info:
* gzip-1.7-1


Steps to reproduce:

Try to build the mathematica package from AUR for example:

gzip: write error: Bad file descriptor
expr: syntax error
Critical Failure in CheckSpace_()
Unix/Installer/MathInstaller: line 3484: [: =: unary operator expected
Unix/Installer/MathInstaller: line 3488: [: =: unary operator expected
Unix/Installer/MathInstaller: line 3484: [: =: unary operator expected
Unix/Installer/MathInstaller: line 3488: [: =: unary operator expected


This task depends upon

Closed by  Sébastien Luttringer (seblu)
Tuesday, 26 April 2016, 16:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  gzip-1.7-2

Loading...