Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49058 - geeqie depends on gtk2 but is a gtk3 application

Attached to Project: Arch Linux
Opened by David Couzelis (drcouzelis) - Saturday, 23 April 2016, 02:27 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 23 April 2016, 13:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The "geeqie" package has a "depends" entry for the package "gtk2", but it is a GTK3 application.

Additional info:
* package version "geeqie-1.2.3-1"
* FYI, the "configure" file has an option "--disable-gtk3" to enable GTK2.

Steps to reproduce:
"ldd /usr/bin/geeqie" to see if it is using "libgtk-x11-2.0.so.0" (GTK2) or "libgtk-3.so.0" (GTK3).
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 23 April 2016, 13:56 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Saturday, 23 April 2016, 04:08 GMT
So it is linked to, and using, gtk2. Is this a request to switch to gtk3?
Comment by David Couzelis (drcouzelis) - Saturday, 23 April 2016, 11:12 GMT
The purpose of the bug report was to point out that "depends" lists "gtk2" but doesn't need it (I think), and "depends" doesn't list "gtk3" which it does use (I think).

Everything is working fine with geeqie and the package, and OBVIOUSLY it compiled just fine. But it looks like geeqie just only recently switched to GTK3 so I thought maybe it was an oversight in the PKGBUILD file.

So, I guess this really isn't a "bug". I guess it's more of a "Huh, this looks strange and doesn't make sense to me. I wonder if the package maintainer knows?". I apologize for the confusion.

If you're asking my opinion, yes, I do prefer GTK2, but no, it's not a request to switch to GTK3.
Comment by Doug Newgard (Scimmia) - Saturday, 23 April 2016, 13:56 GMT
% objdump -p usr/bin/geeqie
...
NEEDED libgtk-x11-2.0.so.0
NEEDED libgdk-x11-2.0.so.0
...

So it currently does need gtk2.

Loading...