Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49053 - [lib32-libgcrypt] Latest update broke Steam

Attached to Project: Community Packages
Opened by Matheus Ribeiro (Ryderr3) - Friday, 22 April 2016, 16:01 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 22 April 2016, 16:13 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: the latest update broke Steam, downgrading to 1.6.5-1 solved the issue.


Additional info:
* package version: 1.7.0-1
* config and/or log files etc:

computador@computador:~$ LIBGL_DEBUG=verbose steam
Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1459463254)
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/tls/i915_dri.so
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/i915_dri.so
libGL: dlopen /usr/lib32/xorg/modules/dri/i915_dri.so failed (/usr/lib32/libgcrypt.so.20: symbol gpgrt_lock_lock, version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference)
libGL error: unable to load driver: i915_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i915
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/swrast_dri.so
libGL: dlopen /usr/lib32/xorg/modules/dri/swrast_dri.so failed (/home/computador/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib32/xorg/modules/dri/swrast_dri.so))
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast


Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 22 April 2016, 16:13 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#48994 

Loading...