Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49035 - [wxsqlite3] pkgconfig file not installed

Attached to Project: Community Packages
Opened by Scott Furry (digifuzzy) - Thursday, 21 April 2016, 07:30 GMT
Last edited by Jaroslav Lichtblau (Dragonlord) - Monday, 02 January 2017, 18:10 GMT
Task Type Feature Request
Category Upstream Bugs
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
speps (archspeps)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

PKG Version: 3.3.1-1

Source for package includes pkg-config template file (wxsqlite3.pc.in).
(src https://github.com/utelle/wxsqlite3/blob/master/wxsqlite3.pc.in )

Talking with upstream, this file was added by upstream maintainer in 2013 on request of Fedora maintainers.

Fedora maintainers alter the *.pc.in file manually in their package building mechanism to produce a *.pc file
(src http://pkgs.fedoraproject.org/repo/pkgs/wxsqlite3/wxsqlite3.spec/bb773f6231aa1e674c603c6a6bd40654/wxsqlite3.spec )

Debian creates and installs their own pc file for this package.
(src http://anonscm.debian.org/cgit/collab-maint/wxsqlite3.git/tree/debian )

I have filed a bug report with upstream (https://github.com/utelle/wxsqlite3/issues/2) WRT the wxsqlite3.pc file not being created. Upstream maintainer mentioned that they are a Windows user and not familiar with autotools. I have offered to assist the upstream maintainer with populating the wxsqlite3 pkg-config file.

Currently Arch community package does nothing with wxsqlite3 pkg-config. There is no mechanism to properly detect wxsqlite3 installation without resorting to manually testing of files.

Until the issue is resolved upstream, I have attached a modified PKGBUILD file for building wxSqlite3. Ideas are "borrowed" from Fedora in manually manipulating the wxsqlite3.pc.in file to produce wxsqlite3.pc ( prepare function ). That file is then installed to the fakeroot directory in the package function.
   PKGBUILD (1.3 KiB)
This task depends upon

Closed by  Jaroslav Lichtblau (Dragonlord)
Monday, 02 January 2017, 18:10 GMT
Reason for closing:  Implemented
Additional comments about closing:  Implemented in wxsqlite3-3.4.1-2
Comment by Scott Furry (digifuzzy) - Saturday, 23 April 2016, 21:12 GMT
Upstream has modified the source to generate a pkg-config file.
Attached is updated PKGBUILD file to reflect these changes.

Loading...