Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49034 - [plasma-workspace] After update to 5.6.3 krunner and containment actions not working

Attached to Project: Arch Linux
Opened by David Rosca (nowrep) - Thursday, 21 April 2016, 07:11 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 21 April 2016, 09:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After updating to 5.6.3 krunner plugins and containment actions (right click on desktop for menu, wheel for switching virtual desktops, ...) are not working. In krunner settings, the plugins are displayed but krunner can't show any search results.

Additional info:
Downgrading to 5.6.2 fixes the issue.


Steps to reproduce:
Open desktop settings -> go to Mouse Actions -> actions are empty and you can't add new.
Try to search for anything in krunner.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 21 April 2016, 09:45 GMT
Reason for closing:  Not a bug
Comment by David Rosca (nowrep) - Thursday, 21 April 2016, 07:32 GMT
Reverting this change is enough to fix it:

- -DLIB_INSTALL_DIR=lib \
- -DLIBEXEC_INSTALL_DIR=lib \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=lib \
Comment by Antonio Rojas (arojas) - Thursday, 21 April 2016, 08:52 GMT
Can't reproduce. Packages build with the old-style and new-style cmake variables are identical here (but the old ones give deprecation warnings at build time).

Did you build the package yourself? Did you use the official, up to date cmake and ECM packages? Please try building in a clean chroot
Comment by David Rosca (nowrep) - Thursday, 21 April 2016, 08:55 GMT
Tried with official 5.6.3 package from repo - broken
Downgraded to official 5.6.2 package from repo - fixed

Built myself 5.6.3 with reverting the above mentioned change in pkgbuild - fixed

Will try building myself 5.6.3 without any change.
Comment by David Rosca (nowrep) - Thursday, 21 April 2016, 09:39 GMT
Self built 5.6.3 without any changes works fine, build from clean chroot no.
I have no idea what's wrong ...
Comment by Antonio Rojas (arojas) - Thursday, 21 April 2016, 09:41 GMT
This sounds like you may have some outdated library on your system. 5.6.3 was built against KF5.21, do you have any non-official frameworks package?
Comment by David Rosca (nowrep) - Thursday, 21 April 2016, 09:44 GMT
Ah yeah, sorry didn't think of it. I have git plasma-framework package.

Sorry again, please close it.

Loading...