Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49018 - [thunderbird-i18n] should now include transations for lightning

Attached to Project: Arch Linux
Opened by Johannes Rohr (jro) - Wednesday, 20 April 2016, 07:45 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 05 April 2017, 19:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Evangelos Foutras (foutrelis)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:


the latest version of thunderbird packaged for Arch Linux comes with Lightning included, following upstream. Could you kindly package the corresponding translations as well?

I'm not sure whether this concerns all localization packages.

Additional info:
* package version(s) 45.0-1
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 05 April 2017, 19:58 GMT
Reason for closing:  Won't fix
Comment by clement (RoyalPanda) - Friday, 20 May 2016, 07:00 GMT
I'm backing up this proposition as en-US localization is the only one provided for lightning in the thunderbird package.
So, for now, we have to uninstall lightning and reinstall it after every thunderbird update.
The difference I found between the version packed and the one I got from mozilla is in the chrome.manifest where every locale are declared in the one from mozilla.

Good luck about it, and thanks for your job by the way.
Comment by Jan Alexander Steffens (heftig) - Friday, 20 May 2016, 11:09 GMT
Are those available as separate XPIs? Or is there one lightning extension for every locale? Or is there a way to get the build to produce an omni-localized extension?

Right now we build the binaries ourselves but grab prebuilt localizations. TBH I don't know how Mozilla builds these. Can you build them out of the regular sources? This also concerns Firefox. I'd love to be able to build binaries and localizations from a single PKGBUILD.
Comment by clement (RoyalPanda) - Thursday, 26 May 2016, 10:23 GMT
There is only one xpi with all locale included : https://addons.mozilla.org/thunderbird/downloads/latest/2313/platform:2/addon-2313-latest.xpi?src=dp-btn-primary
I tried to dig in the sources of thunderbird, but it seems that locale aren't shipped in the 'only Thunderbird' sources. It has to come from the mercurial repository with all the 'mach' build.
Didn't tried this because of the large Go needed. Maybe the easiest way would be to ship the already packaged XPI ? Or to exclude lightning from the build ?
Comment by Wayne Mery (wsmwk) - Thursday, 02 June 2016, 21:01 GMT Comment by Jan Alexander Steffens (heftig) - Wednesday, 05 April 2017, 19:57 GMT
Mozilla does not provide XPIs with localized Lightning. Building localizations ourselves is far too difficult. Hence, I dropped Lightning again.

Loading...