Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49000 - [xf86-input-libinput] Triple-tap locks/freezes touchpad

Attached to Project: Arch Linux
Opened by Konstantin Gizdov (kgizdov) - Monday, 18 April 2016, 01:10 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 19 June 2016, 17:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since recently, whenever I close a tab in Chrome with triple-tap my cursor is locked and the touchpad becomes unresponsive, until I triple-tap again. This is not default/expected behaviour.

Additional info:
* libinput - 1.2.3-1
* X.org conf:

Section "InputClass"
Identifier "MyTouchpad"
MatchIsTouchpad "on"
Driver "libinput"
Option "Tapping" "on"
Option "Tap-to-click" "on"
EndSection


Steps to reproduce:

1. Triple-tap
2. touchpad locks
3. triple-tap again
4. touchpad recovers
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 19 June 2016, 17:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#49523 
Comment by Andreas Radke (AndyRTR) - Monday, 18 April 2016, 16:28 GMT
Please report it upstream.
Comment by Alif (alive4ever) - Sunday, 19 June 2016, 15:39 GMT
Do you mean "triple tap" by "three finger tap"? Tapping the touchpad three times or using three fingers to tap the touchpad once?

There is no problem for me with three finger tap. My /etc/X11/xorg.conf.d/30-touchpad.conf is below.
```
Section "InputClass"
Identifier "MyTouchpad"
MatchIsTouchpad "on"
Driver "libinput"
Option "Tapping" "on"
EndSection
```

There is no need for option "Tap-to-click". See if this fix your problem.

If this doesn't fix your problem, maybe there is something about "palm detection" to prevent touchpad movement during typing.

Loading...