Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#49 - rc.local should automatically start programs in the background

Attached to Project: Arch Linux
Opened by xirus (axel) - Wednesday, 19 March 2003, 18:08 GMT
Last edited by xirus (axel) - Wednesday, 19 March 2003, 19:37 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Judd Vinet (judd)
Architecture All
Severity High
Priority Normal
Reported Version 0.6 Widget
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

I don't know if you can call this a bug, but when you start a deamon (a program that will run infinitely) with rc.local, the system doesn't continue with booting. This is fixed by putting a '&' behind the command, but I think this should be done automatically in order to prevent these kind of lockups...
This task depends upon

Closed by  Anonymous Submitter
Wednesday, 19 March 2003, 19:37 GMT
Reason for closing:  Not a bug
Comment by Judd Vinet (judd) - Wednesday, 19 March 2003, 18:33 GMT
This is not a bug.

Most daemons automatically fork themselves into the background. If a daemon remains in the foreground, then it is the system administrator's responsibility to recognize this and add an ampersand to the command line.

The Arch Linux startup scripts cannot automagically force rc.local commands into the background. Furthermore, not all commands in an rc.local file SHOULD be backgrounded. This is completely open to the admin's discretion. Test your daemons by manually running them before you automate them in a script.
Comment by xirus (axel) - Wednesday, 19 March 2003, 19:37 GMT
  • Task details edited
Maybe say something about this in the manual? I'm not the first one that had a locked system because of this...

Loading...