Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48948 - [linux] 4.5-1 breaks Broadwell-U I2S Audio

Attached to Project: Arch Linux
Opened by Brandon Thomas (uncon) - Thursday, 14 April 2016, 15:22 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 14 April 2016, 15:42 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After upgrading the linux kernel (4.4.5-1 -> 4.5-1), the built-in I2S sound card (Intel Broadwell-U Audio Controller) on my Dell XPS 13 (9343) disappears.

This appears to be due to building the kernel with DW_DMAC_CORE as modular. Apparently, to enable SND_SOC_INTEL_BROADWELL_MACH, it must now be built-in. (Source: https://stijn.tintel.eu/blog/2016/03/14/i2s-audio-on-xps13-linux-45)

# zcat /proc/config.gz | grep "DW_DMAC_CORE=\|DW_DMAC=\|DMADEVICES="
CONFIG_DMADEVICES=y
CONFIG_DW_DMAC_CORE=m
CONFIG_DW_DMAC=m

Additional info:
Rolling back to linux 4.4.5-1 resolves this issue.

Steps to reproduce:
1. Check for sound card in 4.4.5-1
# aplay -l -L | grep broadwell
sysdefault:CARD=broadwellrt286
broadwell-rt286,
card 1: broadwellrt286 [broadwell-rt286], device 0: System Playback/Capture (*) []
card 1: broadwellrt286 [broadwell-rt286], device 1: Offload0 Playback (*) []
card 1: broadwellrt286 [broadwell-rt286], device 2: Offload1 Playback (*) []

2. Upgrade to 4.5-1

3. Note the absence of the sound card
# aplay -l -L | grep broadwell
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 14 April 2016, 15:42 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#48936

Confirmed by looking at the kernel configs. Please post your info over there.
Comment by Doug Newgard (Scimmia) - Thursday, 14 April 2016, 15:38 GMT
Same as FS#48936?

Loading...