Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48911 - [libreoffice-fresh] missing dep on dconf

Attached to Project: Arch Linux
Opened by Alex Suykov (axs) - Tuesday, 12 April 2016, 14:58 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 12 April 2016, 16:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: libreoffice refuses to start without dconf. Installing dconf (and dconf alone) fixes the problem.


Additional info:
libreoffice-fresh 5.1.2-1, gtk2-2.24.30-1, dconf-0.26.0-1, fully updated Arch.
LO startup log attched.


Steps to reproduce:
Uninstall dconf, run libreoffice.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 12 April 2016, 16:54 GMT
Reason for closing:  Not a bug
Comment by Andreas Radke (AndyRTR) - Tuesday, 12 April 2016, 16:01 GMT
From your log it seems you're using gtk3 vcl:

/usr/lib/libreoffice/program/libvclplug_gtk3lo.so(+0x40722)[0x7f94a442c722]

gtk3 depends on colord that depends on dconf. So it should be covered.
Comment by Doug Newgard (Scimmia) - Tuesday, 12 April 2016, 16:03 GMT Comment by Alex Suykov (axs) - Tuesday, 12 April 2016, 16:38 GMT
Ouch, I see the problem. There's no colord installed, there's colord-mini instead which is a custom build without polkit and dconf dependencies. And it works well like that apparently. If I replace colord-mini with extra/colord, that brings dconf in.

Looks like dconf is a direct dependency for something that's usually satisfied via colord. Anyway, I don't think may people use custom colord builds.

This resolves the bug I think, feel free to close it.

Loading...