Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48862 - [emacs] toolbar without icons

Attached to Project: Arch Linux
Opened by Felix E. Klee (feklee) - Sunday, 10 April 2016, 08:27 GMT
Last edited by Jürgen Hötzel (juergen) - Saturday, 04 June 2016, 19:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jürgen Hötzel (juergen)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

Description: Yesterday I updated the system, and now the toolbar icons in EMACS are missing. On another Arch installation I cannot replicate the problem.

What I already tried:

* `emacs --no-init-file`

* disable GDK scaling

Additional info:

* Package version: 24.5-2

Steps to reproduce: Start EMACS, the toolbar is empty.
This task depends upon

Closed by  Jürgen Hötzel (juergen)
Saturday, 04 June 2016, 19:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in
-> emacs-24.5-4-i686.pkg.tar.xz (i686)
-> emacs-24.5-4-x86_64.pkg.tar.xz (x86_64)
Comment by Doug Newgard (Scimmia) - Sunday, 10 April 2016, 08:37 GMT
Using what GTK3 theme? Have you tried the default (Adwaita)?
Comment by kkl2401 (kkl2401) - Sunday, 10 April 2016, 14:27 GMT
The same happens to me. I have the following in ~/.config/gtk-3.0/settings.ini:
gtk-theme-name=Default
So I suppose I use the default theme (I don't really understand GTK3 configuration).
It doesn't bother me much because I don't use the toolbar in Emacs but I can confirm the behavior.
Comment by Manuel Reimer (M-Reimer) - Sunday, 10 April 2016, 14:46 GMT
Downgrading GTK3 resolves this for me.
Comment by Robert Alessi (ralessi) - Monday, 11 April 2016, 19:37 GMT
I think that downgrading gtk3 may break a lot of things. I wouldn't do that.
I tried to recompile emacs with the latest gtk3: same issue, toolbar still missing. Then, as a workaround, I recompiled emacs with gtk2 instead of gtk3: this resolves the issue.
Comment by Felix E. Klee (feklee) - Tuesday, 12 April 2016, 07:53 GMT
Downgrading or recompiling should not be necessary. T̶h̶e̶ ̶t̶o̶o̶l̶b̶a̶r̶ ̶w̶o̶r̶k̶s̶ ̶f̶i̶n̶e̶,̶ ̶a̶f̶t̶e̶r̶ ̶a̶l̶l̶,̶ ̶i̶n̶ ̶a̶n̶o̶t̶h̶e̶r̶ ̶A̶r̶c̶h̶ ̶i̶n̶s̶t̶a̶l̶l̶a̶t̶i̶o̶n̶.̶ Possibly there is a dependency missing somewhere, for example a package with icons. I wonder: How to best debug that?
Comment by Robert Alessi (ralessi) - Tuesday, 12 April 2016, 08:08 GMT
I think this is definitely a bug in the latest gtk3, which is flagged as outdated. We have to wait for the release to come.
Comment by Felix E. Klee (feklee) - Tuesday, 12 April 2016, 08:38 GMT
Personally, I don’t use the toolbar, so no problem for me. However, the user for which I set up the system depends on the toolbar. Also icons need to be scaled up two times for display on a high DPI screen, which means linking against GTK+ 2 is not an option. I am on location only today, and need to fix this ASAP.

What could be a quick workaround? [Roll back][1] packages to, say, a month ago? When did this break?

[1]: https://wiki.archlinux.org/index.php/Arch_Linux_Archive#How_to_restore_all_my_packages_at_a_specific_date
Comment by Robert Alessi (ralessi) - Tuesday, 12 April 2016, 09:05 GMT
On 2016/04/09, namely less than a week ago. gtk3 3.20.3-1 is already in testing though.
Comment by Felix E. Klee (feklee) - Tuesday, 12 April 2016, 10:36 GMT
Rollback about a week was successful, icons back! :)
Comment by Robert Alessi (ralessi) - Tuesday, 12 April 2016, 10:44 GMT
Excellent. Don't miss the next gtk3.
Comment by Eugenio M. Vigo (emvigo) - Wednesday, 13 April 2016, 09:30 GMT
gtk3 3.20.3-1 doesn't fix the problem and I don't find any references to this problem outside Arch Linux, not even upstream. I've tried updating the icon cache manually, but doesn't work either.
Comment by Robert Alessi (ralessi) - Wednesday, 13 April 2016, 10:04 GMT
Then I strongly suspect there be a bug in the new gtk3 3.20 branch, as emacs is not the only one which is affected. It should be reported upstream.

For the time being, as a workaround, I would suggest to recompile emacs with gtk2; this is what I did, and it works perfectly. Just get the sources (https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/emacs), replace 'gtk3' with 'gtk2' in PKGBUILD and recompile with 'makepkg'. Before doing this, as the .tar.xz of emacs is signed, import the public key with 'gpg --recv-keys 7C207910' or launch 'makepkg' with '--skipinteg'.
Comment by Robert Alessi (ralessi) - Wednesday, 13 April 2016, 14:44 GMT
Btw, did you update gkt-update-icon-cache as well?
Comment by Eugenio M. Vigo (emvigo) - Wednesday, 13 April 2016, 15:45 GMT
Yes, I did so.
Comment by Doug Newgard (Scimmia) - Wednesday, 13 April 2016, 15:49 GMT
"Then I strongly suspect there be a bug in the new gtk3 3.20 branch, as emacs is not the only one which is affected."

What else is affected? Emacs is the only one I've heard so far.

"Btw, did you update gkt-update-icon-cache as well?"

That has nothing to do with anything.
Comment by Robert Alessi (ralessi) - Wednesday, 13 April 2016, 16:17 GMT
Iceweasel was affected. It is no longer since the latest update of gtk3 (and gtk-update-icon-cache?). So I reinstalled emacs with gtk3, but the issue is still there.

For the time being, I would recommend to recompile emacs with gtk2, which works perfectly. See my post above.
Comment by Felix E. Klee (feklee) - Wednesday, 13 April 2016, 16:20 GMT
There are reasons to compile against GTK+ 3, though, most notably support for high DPI screens. On the system in question, I’d rather not upgrade Arch until the issue is resolved.
Comment by Robert Alessi (ralessi) - Wednesday, 13 April 2016, 16:30 GMT
Good point as regards high DPI screens. However, is gtk2 that ugly on those screens? If not, it may be worth upgrading while keeping emacs + gtk2 until this issue is fixed. This is at least what I did.
Comment by Felix E. Klee (feklee) - Wednesday, 13 April 2016, 16:33 GMT
GTK+ 3 has features to scale up UI elements, and that’s essential for high DPI displays.
Comment by Robert Alessi (ralessi) - Wednesday, 13 April 2016, 16:43 GMT
Which I didn't notice on my Thinkpad X60 of course! So let's hope that this issue will be fixed soon for those who had to stick pacman.
Comment by Doug Newgard (Scimmia) - Wednesday, 13 April 2016, 16:43 GMT
"Iceweasel was affected."

Iceweasel is Firefox. All of the issues there are theme related. Completely different than this bug.
Comment by Wilmer E. Henao (wilmerhenao) - Sunday, 17 April 2016, 17:07 GMT
I've had the same problem here. On top of what has already been said the icon locations DO work!. The only problem is that I cannot see the icons themselves.

I can live without it because I use command line.
Comment by Mihamina Rakotomandimby (rakotomandimby) - Monday, 18 April 2016, 16:21 GMT
I'm trying https://aur.archlinux.org/packages/emacs-git/ in order to see if it fixed upstream. Did not find a reported bug on https://lists.gnu.org/archive/html/bug-gnu-emacs/2016-04/threads.html
Comment by Mihamina Rakotomandimby (rakotomandimby) - Tuesday, 19 April 2016, 04:46 GMT
https://aur.archlinux.org/packages/emacs-git/ has icons. It is fixed on master branch upstream. I dont know what set of commits did the work, I'll try to see...
Comment by Troy Will (troydwill) - Saturday, 14 May 2016, 19:38 GMT
I installed the webkitgtk package and rebuilt the Arch Linux emacs package. The toolbar icons appear.
NOTE: I was unable to duplicate my positive result. Installing webkitgtk and building Emacs _doesn't_ make the toolbar appear. Sorry for the white noise.
Comment by Andrea (mariolino) - Wednesday, 25 May 2016, 09:07 GMT
The commit that fixes it is

https://github.com/emacs-mirror/emacs/commit/3f4c6d52d345999938bc2d4a53246af4c61ef176

Called: Handle deprecated Gtk+ stuff for version <= 3.10

I have not tried to cherry pick this patch in the 24.5 branch.
Comment by Felix E. Klee (feklee) - Saturday, 04 June 2016, 07:24 GMT
Any idea when this will be officially fixed? As this is a showstopper-bug, the system in question has been without updates for two months.
Comment by Jürgen Hötzel (juergen) - Saturday, 04 June 2016, 17:32 GMT
I was hoping for the upcoming 25.1 release. It's still not yet in sight. I will prepare a new emacs 24.5 release.
Comment by Jürgen Hötzel (juergen) - Saturday, 04 June 2016, 18:14 GMT
@Andreas thank you very much for searching the fix.

No easy cherry-picking here: Merge conflict. Any input appreciated.
Comment by Jürgen Hötzel (juergen) - Saturday, 04 June 2016, 18:51 GMT
OK, backported it... I will test
Comment by Jürgen Hötzel (juergen) - Saturday, 04 June 2016, 19:04 GMT
I just released:

-> emacs-24.5-4-i686.pkg.tar.xz (i686)
-> emacs-24.5-4-x86_64.pkg.tar.xz (x86_64)

should hit your friendly ArchLinux miror soon.

Loading...