FS#48839 - [hunspell-en] Broken spell check

Attached to Project: Arch Linux
Opened by Ralf Mardorf (Ralf) - Friday, 08 April 2016, 17:20 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 12 September 2016, 20:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



today I decided to remove hunspell-en from my pacman.conf's IgnorePkg list. From the last time I reported a bug and avoided an upgrade until today, hunspell-en still is unusable.

The last version that worked was 7.1-3, the current version 2016.01.19-1 is broken.

If I write a mail in Claws and a sentence begins with a word, that inside of a sentence must begin with lower case, but since it's the first word, the first letter is upper case, it's marked as spelling mistake.

$ grep 2016 /var/log/pacman.log | grep upgrade | tail -n4 | head -n1
[2016-04-08 10:35] [ALPM] upgraded hunspell-en (7.1-3 -> 2016.01.19-1)

I marked it with a high priority, since it's a long, long time ago, that the hunspell-en package became unusable.

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 12 September 2016, 20:12 GMT
Reason for closing:  No response
Comment by Andreas Radke (AndyRTR) - Saturday, 09 April 2016, 12:46 GMT
I doubt it's hunspell related. All english user would report back this also for LibreOffice or other applications.
Comment by Ralf Mardorf (Ralf) - Saturday, 09 April 2016, 15:28 GMT
Downgrading hunspell-en solved the issue, that's why I suspect that hunspell-en is the culprit.

$ grep 2016 /var/log/pacman.log | grep grade | grep hunspell-en
[2016-04-08 10:35] [ALPM] upgraded hunspell-en (7.1-3 -> 2016.01.19-1)
[2016-04-08 19:24] [ALPM] downgraded hunspell-en (2016.01.19-1 -> 7.1-3)

FWIW I'm using the en_GB and de_DE dictionaries at the same time and the system language is en_US.

$ locale

Nobody replied to a request on Claws user, http://lists.claws-mail.org/pipermail/users/2016-April/016229.html.
Comment by Doug Newgard (Scimmia) - Saturday, 09 April 2016, 15:39 GMT
Were both of those with hunspell 1.3.4?
Comment by Ralf Mardorf (Ralf) - Saturday, 09 April 2016, 15:52 GMT
Yes, hunspell was upgraded in February.

$ grep 2016 /var/log/pacman.log | grep grade | grep hunspell
[2016-02-03 07:13] [ALPM] upgraded hunspell (1.3.3-3 -> 1.3.4-1)
[2016-04-08 10:35] [ALPM] upgraded hunspell-en (7.1-3 -> 2016.01.19-1)
[2016-04-08 19:24] [ALPM] downgraded hunspell-en (2016.01.19-1 -> 7.1-3)

$ pacman -Q claws-mail-git enchant aspell aspell-en aspell-de hunspell hunspell-en hunspell-de
claws-mail-git 3.13.2.r1.geb08800-1
enchant 1.6.0-7
aspell-en 2016.01.19-1
aspell-de 20151222-1
hunspell 1.3.4-1
hunspell-en 7.1-3
hunspell-de 20151222-1
Comment by Andreas Radke (AndyRTR) - Thursday, 23 June 2016, 18:38 GMT
Status with new hunspell 1.4.x? If it's not solved please get in touch and report is upstream.