Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48827 - [pango] undefined symbol: FcWeightFromOpenType

Attached to Project: Arch Linux
Opened by Muflone (muflone) - Wednesday, 06 April 2016, 17:38 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 07 April 2016, 00:08 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After upgrading testing/pango package 1.40.0-1 a lot of programs issue the following error:
symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: FcWeightFromOpenType

This actually affects many packages like tilda, gnome-session, gnome-encfs, evolution-source-registry, evolution-calendar-factory

Additional info:
* package testing/pango 1.40.0-1


Steps to reproduce:

Upgrade pango and execute gnome-shell 3.20 (both GDM and user session) or tilda.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 07 April 2016, 00:08 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Wednesday, 06 April 2016, 17:46 GMT
What version of fontconfig?

Edit: for the record:
% objdump --dynamic-syms /usr/lib/libfontconfig.so.1 | grep FcWeightFromOpenType
0000000000021e80 g DF .text 000000000000008b Base FcWeightFromOpenType
Comment by Muflone (muflone) - Wednesday, 06 April 2016, 18:03 GMT
I'm sorry, I didn't realized that I had the fontconfig package in IgnorePkg.

The fontconfig version was 2.11.1-2.
After upgrading to the latest 2.11.94-1 version the issue has gone.

Sorry for the noise, invalid bug

Loading...