Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#48815 - [networkmanager] broken wifi-connection after upgrade to 1.0.12-1

Attached to Project: Arch Linux
Opened by Greg (misiunt) - Tuesday, 05 April 2016, 10:56 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 06 April 2016, 17:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No


Description: Lost wifi-connection after upgrade to networkmanager 1.0.12-1.

Additional info:
* package version : networkmanager 1.0.12-1
* config and/or log files etc.
there is a lot of information regarding this bug in including my own issue description as pasted below.

KDE-Plasma-Version 5.6.1
KDE-Frameworks-Version 5.20.0
Qt-Version 5.6.0
Kernel-Version 4.4.5-1-ARCH 64-bit
i5-5200U CPU
8 GiB Memory
WiFi Adapter:
1. PCI WiFi - 03:00.0 Qualcomm Atheros QCA6174 802.11ac - Driver ath10k_pci
2. USB WiFi - Bus 002 Device 003: ID 0b05:17ab ASUSTek Computer, Inc USB-N13 802.11n Network Adapter (rev. B1) [Realtek RTL8192CU] - Driver 8192cu

The PCI-WiFi uses the regular kernel ath10k_pci and has obviously no problems with the new 1.0.12-1 version of networkmanager, but the usb one has.
The question of the driver for the USB-Adapter is sligtly more complex. Since the original kernel driver is broken I use the 8192cu provided by the AUR Package 8192cu-dkms.
The driver is loaded:

# lsmod | grep 8192
8192cu 532480 0
mei 81920 1 mei_me
usbcore 196608 9 btusb,uvcvideo,rtsx_usb,ehci_hcd,ehci_pci,usbhid,8192cu,xhci_hcd,xhci_pci

but there is a strange (at least for me) message from

# dmesg -w | grep 8192
usbcore: registered new interface driver rtl8192cu
rtl8192cu 2-2:1.0 enp0s20u2: renamed from wlan0

It is strange because rtl8192cu is the original broken kernel driver I blacklisted i /etc/modprobe.d.

There are no any further messages regarding neither a *8192* driver nor the enp0s20u2 interface. Networkmanager starts the PCI-WiFi without any issues but the USB-one can only be started via iw link and/or wifi-menu. After I started it with wifi-menue and restarted networkmanager the nm-applet shows the enp0s20u2 interface but it is impossible to connect to it. A dialog generated by KDED5 /KDEINIT5] pops up and requires a passwort to access the wifi-network. You can enter whatever you want. Nothing is accepted and the messages "no password has been entered" and "interface enp0s20u2 will be deactivated" appear.

The only workaround I found was to downgrade networkmanager to the previous version.

Steps to reproduce:
This task depends upon

Comment by chrys (chrys87) - Tuesday, 05 April 2016, 14:15 GMT
I can confirm that here.
Comment by Doug Newgard (Scimmia) - Tuesday, 05 April 2016, 18:51 GMT
"en..." means it's being seen as an ethernet interface.

chrys, is yours being named the same way? What driver are you using?
Comment by Greg (misiunt) - Tuesday, 05 April 2016, 19:00 GMT
afaik is "en*" a valid naming convention for usb-devices as well. Anyway, the wifi-interface named enp0s20u2 works without any issues with networkmanager 1.0.10-2.
Comment by Tobias (0pper) - Wednesday, 06 April 2016, 18:12 GMT
Can confirm. Broke my wifi. Using rtl8188eu.

Downgrading to 10.0.10-2 fixed it.
Comment by chrys (chrys87) - Sunday, 10 April 2016, 17:33 GMT
I attached the output of
lsusb -v
bevore and after the update.
after a downgrade it will work again.
Comment by chrys (chrys87) - Sunday, 10 April 2016, 17:35 GMT
the name of the adapter is wlp0s18f2u2
Comment by Jan Alexander Steffens (heftig) - Sunday, 10 April 2016, 17:38 GMT Comment by Jan Alexander Steffens (heftig) - Sunday, 10 April 2016, 17:41 GMT
If you can, please bisect NM between 11aa07ed (1.0.10-2) and 5fea022c (1.0.12).
Comment by chrys (chrys87) - Monday, 11 April 2016, 08:36 GMT Comment by chrys (chrys87) - Monday, 11 April 2016, 19:26 GMT

this seems to be fixed upstream.
In the upstream ticket also is a workarround:
sudo iwconfig <your wlan device> mode managed
before starting NetworkManager.
seems that the wifi card is set to auto after upgrade. this is wrong.
please check if that solves your problem.
for me i just will wait to the next NM stable -> IgnorePKG.

I hope this helps

Comment by Tommy Holmgren (nordicruler) - Tuesday, 12 April 2016, 04:11 GMT
I have this bug in both arch and opensuse tumbleweed using realtek 8188eu module.
iwconfig <wlan device> mode managed did not work for me. ifconfig <wlan device> down or up i still get Operation not permitted.
I had to compile networkmanager from source and apply this patch:
And networkmanager-1.0.12 now works in both my system.

Compile it or wait for the fix.
Comment by Moritz Sichert (moritzs) - Wednesday, 18 May 2016, 07:51 GMT
For me it still doesn't work with networkmanager-1.2.2-1, using 1.0.12-1 instead works.
Comment by Ossi L (Ossil) - Sunday, 22 May 2016, 09:01 GMT
1.2.2-1 doesn't solve for me, I need manually restart it after boot.
1.0.10 "kind of" works better. Actually it looks that it breaks down fatally and thus gets automatically restarted unlike 1.2.2.
I have USB wifi adapter.

More text at:

And just FYI: installed connman and seems to work just fine.