Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#48789 - 2016.04.01 iso: root's shell is zsh with toxic completion config

Attached to Project: Release Engineering
Opened by mark h (oxyopy) - Sunday, 03 April 2016, 01:12 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Sunday, 03 April 2016, 04:14 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

This ISO goes utterly bonkers on boot due to some sort
of broken zsh completion setup. I'm hoping this was an
oversight: root's shell should be bash/dash or other
compatible Bourne shell.

To reproduce: boot the ISO and watch the fur fly. Try and
execute any command (even "echo ok" won't work).

THIS ISO IS NOT USABLE IN ITS CURRENT STATE, hence the
severity of Critical.

Thanks and keep up the fantastic work!!

--Mark

This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Sunday, 03 April 2016, 04:14 GMT
Reason for closing:  None
Additional comments about closing:  ?????????????????????????????????????
Comment by mark h (oxyopy) - Sunday, 03 April 2016, 01:29 GMT
Hehehe.

Turns out the problem only affects i686 on my iso.

Just downloaded a new copy and the i686 squashfs
is different. The new one is OK; the old one spews
EIO all over the place.

Seems to be fixed, request closure.

Loading...