Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48758 - Segmentation fault in test-suite for lzo version 2.07, 2.08, and 2.09

Attached to Project: Arch Linux
Opened by Isabell Cowan (Izzette) - Wednesday, 30 March 2016, 16:34 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 03 April 2016, 16:56 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When running check() for lzo version 2.07, 2.08, and 2.09 the first test fails with a segmentation fault. I'm not sure if it's a problem with liblzo or the test itself. This does not happen with version 2.06 and earlier. I tracked the call down to the function `lzo_pclock_read_clock_gettime_p_syscall'. I have tried this on two up to date x86_64 Arch Linux systems, but get the same error.

Steps to reproduce:
* Download the core ABS archive.
* Extract core/lzo
* Run makepkg --check in the core/lzo
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 03 April 2016, 16:56 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Wednesday, 30 March 2016, 17:03 GMT
No problems here.

Edit: try building in a clean chroot
Comment by Doug Newgard (Scimmia) - Friday, 01 April 2016, 14:42 GMT
Ping?
Comment by Isabell Cowan (Izzette) - Saturday, 02 April 2016, 03:18 GMT
It built and checked successful on a 3rd Arch system, a much newer install. I have no explanation for the failure on the first two systems. I still can't get it to work, even with the default makepkg.conf and switching out my custom glibc, gcc, binutils for the official packages. Still, I think it's probably not a problem with the PKGBUILD, Arch Linux, or the lzo source.
Comment by Doug Newgard (Scimmia) - Sunday, 03 April 2016, 15:46 GMT
Try using a clean chroot on the problem systems. If it works there, we can say for sure that it's a problem with your setup.
Comment by Isabell Cowan (Izzette) - Sunday, 03 April 2016, 16:51 GMT
Yup, no problems in a clean chroot.

Loading...