Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48746 - [boinc-nox] Missing libxss dependency

Attached to Project: Community Packages
Opened by k2_8191 (k2_8191) - Wednesday, 30 March 2016, 05:08 GMT
Last edited by Felix Yan (felixonmars) - Sunday, 03 April 2016, 12:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
boinc-nox 7.6.31-2 requires libxss package to run "boinc" executable (not the task started by boinc).
However, the dependency for libxss is not listed in https://www.archlinux.org/packages/community/x86_64/boinc-nox/ .
Therefore users who installed the boinc-nox package and had not installed libxss (ex. upgrading) won't be able to run boinc(the boinc process will exit by returning 127).

Additional info:
* package version(s)
At least boinc-nox 7.6.22-1 didn't require libxss, suggesting 7.6.31-2 was configured to build using libxss.

* config and/or log files etc.
Having 7.6.31-2 installed, "ldd /bin/boinc" printed the following output:
linux-vdso.so.1 (0x00007ffd985f6000)
libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007f6123e30000)
libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0x00007f6123bbf000)
libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0x00007f6123748000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f6123544000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f612332e000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f6122fec000)
libXss.so.1 => not found
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f6122dcf000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f6122a4d000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f6122748000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f6122532000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f6122191000)
libidn.so.11 => /usr/lib/libidn.so.11 (0x00007f6121f5d000)
libssh2.so.1 => /usr/lib/libssh2.so.1 (0x00007f6121d2f000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007f6121ae3000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f61217ff000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f61215ce000)
libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007f61213ca000)
/lib64/ld-linux-x86-64.so.2 (0x00007f61240a4000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f61211a7000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007f6120f9a000)
libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007f6120d96000)
libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007f6120b7f000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f612097b000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f6120775000)

* Misc info
This page https://einstein.phys.uwm.edu/forum_thread.php?id=9635 suggests exit code 127 of boinc could indicate that boinc executable has missing libraries.

Steps to reproduce:
1. Run "systemctl start boinc.service" as root.
2. Run "systemctl status boinc.service" and see the systemd unit failed and the boinc process exited by returning 127.
This task depends upon

Closed by  Felix Yan (felixonmars)
Sunday, 03 April 2016, 12:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  7.6.31-3
Comment by Doug Newgard (Scimmia) - Wednesday, 30 March 2016, 05:36 GMT
Namcap confirms

boinc-nox E: Dependency libxss detected and not included (libraries ['usr/lib/libXss.so.1'] needed in files ['usr/bin/boinc'])
Comment by Felix Yan (felixonmars) - Thursday, 31 March 2016, 06:45 GMT
I made some hacks and removed the dependency. Please let me know if boinc-nox 7.6.31-3 works for you without libxss installed.
Comment by k2_8191 (k2_8191) - Sunday, 03 April 2016, 11:37 GMT
boinc-nox 7.6.31-3 works for me without libxss.

Here is ldd output of /bin/boinc:
$ ldd /bin/boinc
linux-vdso.so.1 (0x00007ffe9c6c5000)
libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007f81b17c7000)
libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0x00007f81b1556000)
libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0x00007f81b10df000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f81b0edb000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f81b0cc5000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f81b0aa8000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f81b0726000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f81b0421000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f81b020b000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f81afe6a000)
libidn.so.11 => /usr/lib/libidn.so.11 (0x00007f81afc36000)
libssh2.so.1 => /usr/lib/libssh2.so.1 (0x00007f81afa08000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007f81af7bc000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f81af4d8000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f81af2a7000)
libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007f81af0a3000)
/lib64/ld-linux-x86-64.so.2 (0x00007f81b1a3b000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007f81aee96000)
libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007f81aec92000)
libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007f81aea7b000)

Loading...