Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48679 - [libsndfile] blender VSE - Audio strips play continuously instead of seeking from cursor

Attached to Project: Arch Linux
Opened by Maycne Sonahoz (MaycneSonahoz) - Wednesday, 23 March 2016, 18:46 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 28 July 2016, 18:50 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Medium
Priority Normal
Reported Version 5.0.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is actually an issue i have since the update of libsndfile from 1.0.25-3 to 1.0.26-1, that happened on February 9th for Manjaro (and February 3rd for Arch).
Blender version at that time was 17:2.76.b-3, but the issue is still present with the current version 17:2.77-1.

In Video Sequence Editor, when an audio strip from a FLAC file is played, it plays from the beginning rather than from the cursor position. Furthermore, it keeps playing continuously, even when moving the cursor (either towards the beginning or the end).

Exact steps for others to reproduce the error:
- Create a new Blender VSE project
- Add an audio strip from a FLAC file
- Play the sequence
> the strip is played, OK
- Move the sequence cursor towards the end
> the strip keeps playing continuously instead of playing from the new cursor position, NOK
- Move the sequence cursor towards the beginning
> the strip keeps playing continuously instead of playing from the new cursor position, NOK
- The sequence cursor reaches out of the strip
> the strip is not played, OK

A consequence of this is, if playing a strip cut from a FLAC file (meaning the strip is shorter than the file), i can play the whole file as long as i move the cursor backwards so it stays on the strip.
The issue is also reproduced using an OGG file, but not with a MP3 file.

An issue for this has been opened on Blender's bugtracker, only to find the official release 2.77 does not have the described issue: https://developer.blender.org/T47699
A Manjaro core developer confirmed that Manjaro uses Arch's package: https://forum.manjaro.org/index.php?topic=32352

In order to reproduce the issue, the test project posted on Blender's can be used: https://developer.blender.org/F297826
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 28 July 2016, 18:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.0.27-1
Comment by Maycne Sonahoz (MaycneSonahoz) - Saturday, 26 March 2016, 17:06 GMT
A bug report on libsndfile seems to match the issue. That report is fixed already, so the issue should be resolved with its next release or with the according patch: https://github.com/erikd/libsndfile/issues/124
From https://developer.blender.org/T47699#366410
Comment by Maycne Sonahoz (MaycneSonahoz) - Thursday, 28 July 2016, 17:55 GMT
I confirm the issue is fixed in 1.0.27-1. :)

Loading...