Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48647 - [xfce4-settings] please apply upstream patch to allow Intel graphics to suspend/wake

Attached to Project: Arch Linux
Opened by John (graysky) - Sunday, 20 March 2016, 18:53 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 07 August 2016, 09:02 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Related to https://bugs.archlinux.org/task/47997 but the root cause of that ticket was in fact xfce4-settings not processing kernel changes correctly that resulted in the display staying asleep under kernel v4.4.x and v4.5.x. See this (https://bugzilla.xfce.org/show_bug.cgi?id=11107) upstream xfce4 ticket wherein a patch has been proposed that on my system and on another user's system (comment #55) fixes the problem. I have attached it here for your convenience.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 07 August 2016, 09:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  xfce4-settings 4.12.0-5
Comment by Pablo Lezaeta (Jristz) - Monday, 21 March 2016, 06:10 GMT
Do you think they will release a new version (upstream) of that package with the patch in the fasible future (like few weeks)?
Comment by John (graysky) - Monday, 21 March 2016, 07:33 GMT
@Jristz - No, I do not. The upstream bug report I referenced has been open since Aug/2014. Xfce4 has a notoriously slow development cycle.
Comment by Doug Newgard (Scimmia) - Wednesday, 23 March 2016, 16:48 GMT
Unfortunately, Evangelos Foutras is the one that deals with Xfce. He's on mandatory military service, so he isn't around much right now.
Comment by John (graysky) - Wednesday, 23 March 2016, 18:47 GMT
Thanks Doug. At least users savvy enough to search the bug track will happen upon this solution. BTW, I have experienced dozens of monitor sleep/wake cycles with this patch applied under linux v4.4.6 and have not experienced the problem again.

Loading...