Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48631 - [alsa-utils] Loud pop sound after resuming from suspend

Attached to Project: Arch Linux
Opened by ilya (leniviy) - Saturday, 19 March 2016, 09:35 GMT
Last edited by David Runge (dvzrv) - Tuesday, 08 June 2021, 19:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

alsa-utils installs /etc/pm/sleep.d/90alsa which runs the command:

aplay -d 1 /dev/zero

to wake the sound card.

The problem is that the default aplay format is *unsigned* resulting a U-like waveform. Please add "-f cd" arguments to aplay.

Additional info:
* package version(s)
alsa-utils 1.1.0-1
This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 08 June 2021, 19:28 GMT
Reason for closing:  Works for me
Additional comments about closing:  This issue is for a long outdated version of alsa-utils. If the issue persists with recent versions of the software, please open an upstream ticket.
Comment by Doug Newgard (Scimmia) - Saturday, 19 March 2016, 15:09 GMT
People still use pm-utils? Who knew?
Comment by Anatol Pomozov (anatolik) - Saturday, 19 March 2016, 20:35 GMT
Just to clarify. By default "-f U8" is used and with this format zero means the lowest possible PCM value. Thus at start and stop we have audible signal discontinuity. We need to use any signed format that represents zeros as silence. Is it correct?
Comment by ilya (leniviy) - Sunday, 20 March 2016, 06:50 GMT
Anatol: yes, that's what I meant.
I ran the command in terminal and heard that sound and adding "-f cd" fixed that.

However, thanks to Doug, I know my issue is different, because I don't have pm-utils installed. Something else is causing same sound.

Loading...