Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48629 - [graphicsmagick] Binaries can't be found

Attached to Project: Arch Linux
Opened by acar burak (fluxboxer) - Saturday, 19 March 2016, 08:12 GMT
Last edited by Gaetan Bisson (vesath) - Friday, 25 March 2016, 22:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Gaetan Bisson (vesath)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

None of the gm commands works, they produce nothing. "gm display" produces nothing, but "/usr/bin/gm display" works.

Additional info:
* package version(s): graphicsmagick-1.3.23-2
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Gaetan Bisson (vesath)
Friday, 25 March 2016, 22:00 GMT
Reason for closing:  Works for me
Comment by acar burak (fluxboxer) - Saturday, 19 March 2016, 12:16 GMT
Installing graphicsmagick-imagemagick-compat from AUR solves the issue (removing imagemagick!).
Comment by acar burak (fluxboxer) - Saturday, 19 March 2016, 13:44 GMT
Yet, I still get this error trying to launch scribus (1.5/svn etc.):

magick/error.c:921: ThrowLoggedException: Assertion `exception->signature == 0xabacadabUL' failed.

And the scribus dev says that "This indicate the error occurs in graphicsmagick code, not in scribus".
Comment by Doug Newgard (Scimmia) - Saturday, 19 March 2016, 14:31 GMT
What does `which gm` give you?
Comment by acar burak (fluxboxer) - Saturday, 19 March 2016, 14:32 GMT
/usr/bin/gm
Comment by Gaetan Bisson (vesath) - Saturday, 19 March 2016, 21:16 GMT
Sorry but I fail to reproduce your issue. I'm running graphicsmagick-1.3.23-2 on an up-to-date system (make sure you run `pacman -Syu` before reporting a bug) and the gm command works as expected from the command line: `gm convert bla.png bla.jpg` converts the given png file to jpg.

If you want us to investigate your issue, you have to give us detailed steps so we can reproduce it.
Comment by J. S. (Laser) - Friday, 25 March 2016, 17:33 GMT
Unable to reproduce.
graphicsmagick and imagemagick installed, no compat.

Loading...