Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#48598 - [virtualbox-guest-utils] Xorg in archlinux guest cannot be launched after upgrading to linux 4.5-1

Attached to Project: Community Packages
Opened by Frederic Bezies (fredbezies) - Tuesday, 15 March 2016, 18:52 GMT
Last edited by Balló György (City-busz) - Tuesday, 26 April 2016, 09:15 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No


Description: I had to use an Archlinux guest with testing repositories enabled in it. When I upgrade to kernel 4.5.0, Xorg won't launch.

In log, I got this error in Xorg.0.log

"Fatal server Error:
(EE)AddScreen/ScreenInit failed for driver 0"

Additional info:
* Linux kernel : 4.5-1
* Kernel headers : 4.5-1
* virtualbox : 5.0.16-3
* virtualbox-guest-dkms : 5.0.16-3

Steps to reproduce:

1) Install an Archlinux in VirtualBox with guest-dkms and guest-utils packages. Add Mate and Lightdm
2) Activate testing repositories, apply updates and reboot. Lightdm won't load.
This task depends upon

Closed by  Balló György (City-busz)
Tuesday, 26 April 2016, 09:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  virtualbox 5.0.18-1
Comment by Doug Newgard (Scimmia) - Wednesday, 16 March 2016, 00:04 GMT
And do you have the appropriate headers installed for your chosen kernel?
Comment by Frederic Bezies (fredbezies) - Wednesday, 16 March 2016, 07:24 GMT
Of course, related linux-headers package are installed.

I tried from scratch, activating testing and community from the beginning in VirtualBox 5.0.16.

Installation time :
1) pacstrap /mnt base base-devel linux-headers grub
2) genfstab and arch-chroot to setup system
3) restart
4) Added xorg-server, xorg-server-utils, xorg-xinit, virtualbox-guest-utils (which include virtualbox-dmks)
5) Added mate and lightdm with gtk-greeter
6) activate vboxservice
7) restart
8) try to launch lightdm. Nothing but a blinking cursor.

Adding Xorg.0.log to this comment.
Comment by Frederic Bezies (fredbezies) - Sunday, 20 March 2016, 19:13 GMT
I tried today with stable kernel. No problem at all. Xorg can be launched flawlessly. Looks like it is a bug with kernel 4.5-1 :(
Comment by Frederic Bezies (fredbezies) - Thursday, 14 April 2016, 13:23 GMT
  • Field changed: Percent Complete (100% → 0%)
This bug will block stable users. Looks like this issue is known and fixed with this commit on virtualbox guest utils :

So, an update is needed on virtualbox-guest-utils.
Comment by José Jorge (mexchip) - Thursday, 14 April 2016, 23:50 GMT
I think severity should be elevated, Linux kernel 4.5.0-1 is now in the stable repositories and upgrading to it will block VirtualBox users, it happened to me a couple of minutes ago, I'm attaching Xorg.0.log.
Comment by Stefan Majewsky (majewsky) - Friday, 15 April 2016, 08:07 GMT
As a workaround, add "iomem=relaxed" to the kernel command line. I just confirmed it on my VM.

Comment by Frederic Bezies (fredbezies) - Monday, 18 April 2016, 12:32 GMT
  • Field changed: Percent Complete (100% → 0%)
Sorry, but it is still broken. Looks like it needs another patch.

Still need to use grub line workaround in order to get a working X.

Looks like this patch is needed : because it is truely related to Xorg this time!

You can see this : "bugref:8087: Additions/x11: support non-root X server: revert r105407: do not start the display part of VBoxClient at all when not using the user space X.Org vboxvideo driver: all guest systems capable of running the kernel driver should already have equivalent functionality."
Comment by Frederic Bezies (fredbezies) - Monday, 18 April 2016, 20:20 GMT
Well, as VirtualBox 5.0.18 was released today... :D

"VirtualBox 5.0.18 (released 2016-04-18)"

* Linux hosts / guests: Linux 4.5 fixes (bug #15251)
* Linux hosts / guests: Linux 4.6 fixes (bug #15298)
* Linux Additions: added a kernel graphics driver to support graphics when X.Org does not have root rights (bug #14732)
* Linux/Solaris Additions: fixed several issues causing Linux/Solatis guests using software rendering when 3D acceleration is available
Comment by Aleks (pethead) - Tuesday, 19 April 2016, 07:21 GMT
After upgrading VBox to 5.0.18 and reinstalling ./VBoxLinuxAdditions X runs without iomem=relaxed in kernel parameters!