Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48549 - [xorg-server] 1.18.2 freeze desktop on i915

Attached to Project: Arch Linux
Opened by Tomasz Przybył (FadeMind) - Saturday, 12 March 2016, 18:52 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 19 March 2016, 11:25 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

After installing lastest Xorg update 1.18.2 and reboot I have serious issue . After while whole GUI just freeze Mouse and Keyboard not repond at all. Only hard power off (via pushing power button 5 sec. works) shutdown laptop.
I using linux-zen kernel 4.4.5 now.
In Xorg I have weird:

[ 232.965] (II) GetModeLine - scrn: 0 clock: 71800
[ 232.965] (II) GetModeLine - hdsp: 1366 hbeg: 1414 hend: 1446 httl: 1526

in lots of lines after launching google-chrome too.

After revert to 1.18.1 freeze issue not happened. GetModeLine msgs gone in Xorg log.

HW
inxi -G
Graphics: Card-1: Intel 3rd Gen Core processor Graphics Controller
Card-2: NVIDIA GF108M [GeForce GT 630M]
Display Server: X.Org 1.18.2 driver: intel Resolution: 1366x768@60.01hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 11.1.2

During writing this report issue not happened jet but will happened.

This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 19 March 2016, 11:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  xorg-server-1.18.2-3
Comment by Laurent Carlier (lordheavy) - Saturday, 12 March 2016, 19:19 GMT
You should fill a bug upstream at https://bugs.freedesktop.org , then paste the link here
Comment by Tomasz Przybył (FadeMind) - Saturday, 12 March 2016, 19:29 GMT Comment by Jens Adam (byte) - Saturday, 12 March 2016, 19:56 GMT
No problems here (-ARCH and -grsec kernels, KDE, x86_64, i5 GPU)
$ inxi -G:
Card: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
Display Server: X.Org 1.18.2 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz
GLX Renderer: Mesa DRI Intel Ivybridge Desktop GLX Version: 3.0 Mesa 11.1.2
Comment by Shulhan (sulhan) - Sunday, 13 March 2016, 00:11 GMT
No problem here either.

ms 0 % inxi -SG
System: Host: xenom-bubu Kernel: 4.4.5-1-ARCH x86_64 (64 bit) Desktop: i3 4.12-6-g42f5a6c Distro: Arch Linux
Graphics: Card: Intel Crystal Well Integrated Graphics Controller
Display Server: X.Org 1.18.2 driver: intel Resolution: 1600x900@60.01hz
GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 11.1.2
Comment by Duncan Idaho (duncanidaho) - Sunday, 13 March 2016, 08:50 GMT
I have a similar problem. I do not think that the GUI freezes, I have the impression that only Mouse and Keyboard stopped working.

HW:
VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

@OP: Try to add your user to the input group.
Comment by Christoph Haag (haagch) - Sunday, 13 March 2016, 09:23 GMT
Same for me with ivy bridge, xf86-video-intel git with sna. With uxa it happens less, but still happens.

Also keep an eye out for 100% cpu usage of xorg that may start randomly at some point.
Comment by Duncan Idaho (duncanidaho) - Sunday, 13 March 2016, 09:59 GMT Comment by Frederic Bezies (fredbezies) - Sunday, 13 March 2016, 10:51 GMT
No problem for both my eeePC and my Toshiba laptop, both using intel graphical chipset.

For my eeePC :

[fred@fredo-arch-eeepc ~]$ inxi -SG
System: Host: fredo-arch-eeepc Kernel: 4.4.5-1-ARCH i686 (32 bit)
Desktop: MATE 1.12.1 Distro: Arch Linux
Graphics: Card: Intel Mobile 945GSE Express Integrated Graphics Controller
Display Server: X.Org 1.18.2 driver: intel
Resolution: 1024x600@60.00hz
GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2
GLX Version: 2.1 Mesa 11.1.2

For my Toshiba laptop :

[fred@fredo-arch-laptop ~]$ inxi -SG
System: Host: fredo-arch-laptop Kernel: 4.4.5-1-ARCH x86_64 (64 bit)
Desktop: MATE 1.13.0 Distro: Arch Linux
Graphics: Card: Intel Mobile 4 Series Integrated Graphics Controller
Display Server: X.Org 1.18.2 driver: intel
Resolution: 1280x800@59.98hz
GLX Renderer: Mesa DRI Mobile Intel GM45 Express
GLX Version: 2.1 Mesa 11.1.2
Comment by Leho Kraav @lkraav (lkraav) - Sunday, 13 March 2016, 11:42 GMT
I have the same GetModeLine spam happening with Chrome on Gentoo after installing 1.18.2.
Comment by Carlos jimenez (ozmage) - Tuesday, 15 March 2016, 00:50 GMT
Hello I have similar problems with xorg 1.18.2 and intel ironlake here my system just start lagging only installing packages with pacman
and i think this xorg have a memory leak because my system used all the memory and all the swap only watching youtube videos and i can confirm this problem is not only on archlinux i have a custom installation of gentoo linux and my system just start lagging opening google-chrome .

Graphics: Card: Intel Core Processor Integrated Graphics Controller
Display Server: X.Org 1.18.2 driver: intel
Resolution: 1366x768@60.17hz
GLX Renderer: Mesa DRI Intel Ironlake Mobile
GLX Version: 2.1 Mesa 11.1.2

im using DRI3 too but i dont think this is the problem because everything work fine with 1.18.1
Comment by Laurent Carlier (lordheavy) - Friday, 18 March 2016, 14:26 GMT
Can you test packages here: http://pkgbuild.com/~lcarlier/xorg-test/ ?

Thanks
Comment by Loose_Control (Loose_Control) - Friday, 18 March 2016, 17:23 GMT
I just upgraded to testing and i think hit this problem.
In my case the screen would freeze for about 2/3s and after that i could see xorg with about ~50% CPU load for a moment (in ksysguard)

With the test packages the issue seems to be gone.
Comment by Tomasz Przybył (FadeMind) - Friday, 18 March 2016, 18:15 GMT
@Laurent Carlier (lordheavy)
After upgrade to 1.18.2-2.1 and first usage I don't have freeze like it was in 1.18.2-1.

Thanks.

If issue will return (after more time of using) I will feedback ASAP, but for now it is just working, and I don't have desktop freeze.

Loading...