Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48502 - [linux-lts] xorg session flickers after resume from suspend

Attached to Project: Arch Linux
Opened by Davis Forquer (d.forquer) - Tuesday, 08 March 2016, 10:10 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 17 April 2016, 07:08 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Xorg session flickers after resume from suspend. Restarting Xorg solves the issue.

The problem occurs in linux-lts 4.1.18-1 and linux-lts 4.1.19-1.
Downgrading to linux-lts 4.1.17-1 solves the issue.

Journal doesn't have any relevant messages (compared logs with 4.1.17-1 and 4.1.19-1 running kernel).

Additional info:
* Laptop: Medion Akoya
* CPU: Intel(R) Core(TM) M-5Y71 CPU @ 1.20GHz
* core/linux-lts 4.1.18-1, 4.1.19-1 affected. 4.1.17 is not affected

Steps to reproduce: put machine to suspend, resume.


Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 17 April 2016, 07:08 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Tuesday, 08 March 2016, 13:26 GMT
Upstream regression. Please git bisect it and report it to the upstream kernel devs.
Comment by Davis Forquer (d.forquer) - Tuesday, 08 March 2016, 13:59 GMT
Alright, thanks! I can do git bisect
Comment by Andreas Radke (AndyRTR) - Friday, 01 April 2016, 17:03 GMT
Status?
Comment by Andreas Radke (AndyRTR) - Thursday, 14 April 2016, 19:19 GMT
Please check with lts 4.4.7.
Comment by Davis Forquer (d.forquer) - Saturday, 16 April 2016, 20:27 GMT
I did git bisect and submitted the bug upstream right after I submitted it here. It turned out later that it was corrected in a newer version. I have just checked 4.4.7 and it works flawlessly. Sorry, for missing the comment dated by 1st of April.

Loading...