Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48438 - [oxygen-gtk2] lets mysql-workbench segfault

Attached to Project: Arch Linux
Opened by Marcel Korpel (Marcel-) - Thursday, 03 March 2016, 21:51 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 03 March 2016, 22:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is a follow-up of  FS#48313 :

"When trying to set indexes or foreign keys in mysql-workbench 6.3.6-4, especially when trying to set Foreign Key Options (ON DELETE/UPDATE CASCADE/RESTRICT/etc.), the program crashes often, especially when setting these things repeatedly (almost always within 2 minutes). Included is the output of

strace mysql-workbench > mysql-workbench-stdout.txt 2> mysql-workbench-stderr.txt

and a copy of the mwb file, though this issue isn't restricted to this file alone."

It turns out that oxygen-gtk2 is to blame: without this theme installed (and removing the theme setting in .gtkrc-2.0) mysql-workbench doesn't segfault.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 03 March 2016, 22:34 GMT
Reason for closing:  Upstream
Comment by Marcel Korpel (Marcel-) - Thursday, 03 March 2016, 21:52 GMT
BTW, the issue is with version oxygen-gtk2-1.4.6-2.
Comment by Antonio Rojas (arojas) - Thursday, 03 March 2016, 22:34 GMT
Not a packaging problem, report this upstream

Loading...