Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48424 - [p7zip] 7z command line : unable to open the new RAR5 format

Attached to Project: Arch Linux
Opened by Alif (alive4ever) - Thursday, 03 March 2016, 01:46 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 05 March 2016, 04:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Command line 7z doesn't recognize new RAR5 archive format.

Additional info:
* package version : 9.38.1-4
* config and/or log files: none


Steps to reproduce:

Create a rar5 archive, for example from Android phone using RAR application, by selecting RAR format.
Transfer the file to Archlinux machine.
Install p7zip from official repository.
List the file content using 7z command line

`7z l test.rar`

Notice that the rar5 archive is not recognized.

I've attached a patch to fix this bug.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 05 March 2016, 04:50 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Thursday, 03 March 2016, 03:16 GMT
So the current version doesn't support it? That's not a bug.

Loading...