Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48420 - [notion] pulling both sources from non-static git HEAD

Attached to Project: Community Packages
Opened by Levente Polyak (anthraxx) - Thursday, 03 March 2016, 00:33 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 09 March 2016, 13:43 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hi, during some tests I observed that the current PKGBUILD is pulling both 2 soruces directly the git HEAD.
I assume this was just a small accident, however it would be great if this could be fixed and a updated version released.

Just in case, a small explanation:
Packages should always be re-buildable and reproducible, which requires PKGBUILD source option to point to the very same upstream version/source. If it is not possible to reference a release tarball (because there may not be any) then it should be pinned to a static git commit hash.

cheers,
Levente
This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 09 March 2016, 13:43 GMT
Reason for closing:  Fixed

Loading...