Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48392 - [linux] GUI stuttering every ~15 sec since Kernel 4.4

Attached to Project: Arch Linux
Opened by Faule Socke (socke) - Tuesday, 01 March 2016, 20:35 GMT
Last edited by Jan de Groot (JGC) - Thursday, 05 October 2017, 07:39 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The GUI "stutters" (which means it does not update for some part of a second) every ~15 seconds since kernel 4.4. I've measured the time with a simple stopwatch and these 15 seconds are really consistent. When it stutters, even the mouse hangs.


Additional info:
Happens since Kernel 4.4, I tried with core/linux in 4.4.1-2 as well as testing/linux in 4.4.3-1. There is nothing suspicious in the system log. It works perfectly fine when I downgrade the system to kernel 4.3.

My system is a Lenovo Thinkpad L530. Here is some more info:

% lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
06:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

% cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 58
model name : Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
stepping : 9
microcode : 0x19
cpu MHz : 1299.414
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt
bugs :
bogomips : 4990.38
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:
[show 3 more cores]

If you need any additional information like loaded drivers or something, just ask.


Steps to reproduce:
Just move the mouse cursor and see it stuttering every ~15s or run glxgears or some other animation and see how it hangs every ~15s for maybe half a second.
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 05 October 2017, 07:39 GMT
Reason for closing:  Fixed
Comment by Faule Socke (socke) - Tuesday, 07 June 2016, 10:29 GMT
Update: It looks like this problem (which still exists in 4.6.1-2) is wifi related. Wifi is default on after startup. If I disable (or re-enable) it by pressing Fn+F5 the problem disappears. Funfact: If I disable wifi via "rfkill block 1" after startup, the problem persists. I have to use the Fn+F5 key to disable wifi "correctly". Also: When wifi is disabled at any time via rfkill block, pressing Fn+F5 does not re-enable it on the first keypress. I have to press Fn+F5 twice to enable wifi again (or use rfkill unblock).

Regards
Comment by mattia (nTia89) - Monday, 02 October 2017, 20:39 GMT
is this issue still valid?
Comment by Faule Socke (socke) - Wednesday, 04 October 2017, 08:45 GMT
I'm not using Arch anymore but AFAIR the problems disappeared some time ago. Also, I don't have problems with my currently running 4.12.13 kernel.

Loading...