Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48372 - [mpd] no socket activation support

Attached to Project: Arch Linux
Opened by Thomas B├Ąchler (brain0) - Sunday, 28 February 2016, 23:35 GMT
Last edited by Gaetan Bisson (vesath) - Tuesday, 01 March 2016, 00:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Latest mpd in extra lacks system activation support. This is due to systemd disabling the compat .pc files. The problem is solved in mpd master, but backporting this patch is not trivial. The easiest way to solve this is by patching the PKGBUILD:

Add a prepare() function:

prepare() {
mkdir -p "${srcdir}"/pkg-config
ln -s /usr/lib/pkgconfig/libsystemd.pc "${srcdir}"/pkg-config/libsystemd-daemon.pc
}


And in build(), add PKG_CONFIG_PATH="${srcdir}"/pkg-config on the configure line.
This task depends upon

Closed by  Gaetan Bisson (vesath)
Tuesday, 01 March 2016, 00:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  mpd-0.19.13-2 in [extra]
Comment by Gaetan Bisson (vesath) - Monday, 29 February 2016, 03:57 GMT
Could you please check mpd-0.19.13-2 from [testing] indeed works as you expect?
Comment by Peter Mattern (krabat) - Monday, 29 February 2016, 13:44 GMT
Problem seems to be fixed in 0.19.13-2.

Finding here was if only mpd.socket was enabled while mpd.service wasn't both behaved as expected upon boot but as soon as a connection attempt was made by a client both failed with mpd throwing an error message "socket: Failed to bind to '[::]:6600': Address already in use".
As of 0.19.3-2 everything is working again without any further tweaking.

Loading...