Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48313 - [mysql-workbench] Segfault when changing indexes or foreign keys

Attached to Project: Community Packages
Opened by Marcel Korpel (Marcel-) - Tuesday, 23 February 2016, 20:33 GMT
Last edited by Christian Hesse (eworm) - Thursday, 03 March 2016, 22:17 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to set indexes or foreign keys in mysql-workbench 6.3.6-4, especially when trying to set Foreign Key Options (ON DELETE/UPDATE CASCADE/RESTRICT/etc.), the program crashes often, especially when setting these things repeatedly (almost always within 2 minutes). Included is the output of

strace mysql-workbench > mysql-workbench-stdout.txt 2> mysql-workbench-stderr.txt

and a copy of the mwb file, though this issue isn't restricted to this file alone.
This task depends upon

Closed by  Christian Hesse (eworm)
Thursday, 03 March 2016, 22:17 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Well, at least not my bug...
Comment by Christian Hesse (eworm) - Wednesday, 24 February 2016, 21:04 GMT
I am not sure when this happens: Do you edit the model when it crashes? Or do you edit real database on a server (and the model is for reproduction)?
Comment by Marcel Korpel (Marcel-) - Wednesday, 24 February 2016, 21:26 GMT
I'm editing the model (by double-clicking on a table in the EER diagram or in the MySQL model tab).
Comment by Christian Hesse (eworm) - Thursday, 03 March 2016, 14:03 GMT
Looks like oxygen-gtk2 is involved. Can you remove that package and try again?
Comment by Marcel Korpel (Marcel-) - Thursday, 03 March 2016, 21:25 GMT
Good catch. I removed the package (and the theme setting in .gtkrc-2.0) and mysql-workbench doesn't segfault anymore.

So, after all, should we file a bug against oxygen-gtk2?
Comment by Christian Hesse (eworm) - Thursday, 03 March 2016, 21:38 GMT
I've never used oxygen-gtk2... But I suppose that is to blame. Feel free to file bug report. ;)
Are you ok to close this bug?
Comment by Marcel Korpel (Marcel-) - Thursday, 03 March 2016, 21:45 GMT
Of course.

Loading...