Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48277 - [yaml-cpp] boost is needed as a dependency, not just as a makedependency

Attached to Project: Community Packages
Opened by Baptiste (zorun) - Saturday, 20 February 2016, 21:54 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 21 February 2016, 01:37 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since the headers of yaml-cpp include boost headers, boost is actually needed to compile software against yaml-cpp. For instance, compiling asciiportal-git from the AUR without installing boost fails:

In file included from /usr/include/yaml-cpp/node/node.h:17:0,
from /usr/include/yaml-cpp/yaml.h:16,
from src/ap_maps.cpp:6:
/usr/include/yaml-cpp/node/ptr.h:11:32: fatal error: boost/shared_ptr.hpp: No such file or directory
compilation terminated.

Thus, I think that boost should be moved to depends instead of makedepends.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 21 February 2016, 01:37 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Saturday, 20 February 2016, 23:05 GMT
No, boost should be added as a makedepend of asciiportal-git instead.
Comment by Baptiste (zorun) - Sunday, 21 February 2016, 00:38 GMT
Yes, sorry, you are right. I was confused by the fact that it's only a header issue. Indeed, to *use* something built with yaml-cpp, the boost headers are useless, so they should not be a dependency.

Loading...